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Introduction Welcome

Introduction

Welcome
RFXpress RFX100 is a software application that creates digitally modulated baseband, IQ, IF, RF, and
UWB-WiMedia signals that can be generated through arbitrary waveform generators (AWG). This
software runs as an integral part of AWG5000 and AWG7000 series arbitrary waveform generators and
can also run from an external PC.

Using RFXpress RFX100 (referred to as RFXpress), you can define baseband I and Q signals with various
modulation schemes and create single or multi-carrier signals where each carrier can be independently
defined. For each carrier, you can apply impairments such as quadrature error and I/Q imbalance, add
interferences such as sinusoidal interference, and define the graphs to create. Upon compilation, the signal
can be viewed as graphs, sent to an arbitrary waveform generator, and saved for later use. Compilation
options include sending signals directly to the AWG and completely eliminating the wrap-around
effects found in arbitrary waveform generators. This provides seamless signals that can be played back
continuously without any discontinuity or glitch in the time, frequency, modulation, or channel coding
domains. Waveform transfer and control of the AWG5000 and AWG7000 series can be performed directly
from RFXpress.

Waveforms captured from oscilloscopes and real-time spectrum analyzers can be modified in RFXpress
before they are regenerated.

You can create UltraWideBand WiMedia signals in the Conformance and Custom modes. In the
conformance mode, you can either select a standard setup or define your own setup based on the UWB
standards. In the Custom mode, you can create a customized signal by defining packet parameters and
setting processing preferences. The Calibration feature for the UWB-WiMedia module allows you to
create correction files and apply these correction files to channels during compilation.

Related Documentation
In addition to this RFXpress Online Help, the following documentation is included with the software:

RFXpress Installation Manual (Tektronix part number 071-2166-XX). The installation manual has
information about installing and upgrading the software.

RFXpress User Manual (Tektronix part number 077-0045-XX). The user manual is adapted from
the online help and is available in PDF format.

RFXpress Quick Start User Manual (Tektronix part number 071-2167-XX). The quick start user
manual has information about using the software creating IF/IQ/RF signal output.

For WiMedia standards, please refer to the MultiBand OFDM Physical Layer Specification Version 1.2
(Draft) by WiMedia Alliance.
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Conventions
The online help uses the following conventions:

When steps require a sequence of selections using the software interface, the ">" delimiter marks each
transition between a menu and an option. For example, File > Save.

DUT refers to the Device Under Test

Three dots (...) following a menu item indicates that the menu item will open a submenu.

The terms "signal" and "waveform" are used interchangeably.

Feedback
Tektronix, Inc.

14200 SW Karl Braun Drive

P.O. Box 500

Beaverton, OR 97077

USA

For product information, sales, service, and technical support:

In North America, call 1-800-833-9200.

Worldwide, visit www.tektronix.com to find contacts in your area.
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Getting Started

Minimum System Requirements
The minimum requirements for the offline version of the application are listed in the following table.

Table 1: Minimum system requirements
OS Supported Minimum Requirements
Windows XP Professional
Service Pack 2.1

2.0 GHz or higher
512 MB RAM
2 GB free disk space
Microsoft Internet Explorer 6.01 or higher
.NET 2.0 runtime
1024 x 768 display resolution with 120 dpi font size

xxx

You will need TekVisa version 3.0.2 Build 33 or above to send data to a Tektronix arbitrary waveform
generator. If TekVisa is not already installed in your PC, you can download the software from
www.tektronix.com/software.

Ordering RFXpress
RFXpress can be ordered as follows:

Table 2: Ordering RFXpress
Part number Description
RFX100 Base Software: RFXpress for General Purpose IQ, IF, and

RF signal creation
Opt. UWBCF RFXpress plug-In for UWB-WiMedia IQ, IF, and RF

conformance signal creation (requires RFX100 as
prerequisite)

Opt. UWBCT RFXpress plug-in for UWB-WiMedia IQ, IF, and RF custom
and conformance signal creation (requires RFX100 as
prerequisite and includes Option UWBCF)

xxx
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Installation
An installation wizard installs RFXpress. If you have not installed TekVisa ver 3.0.2 Build 33 and .NET
2.0, you will be notified during installation. You can cancel the installation any time during the process.

For details on how to install the software, refer to the RFXpress Installation Manual (Tektronix part
number 071-2166-xx) available as a PDF on the CD-ROM.

You can uninstall RFXpress in either of the two ways:

From Start > Programs > Tektronix RFXpress > RFXpress Uninstallation

From Add/Remove programs in Control panel.
Connection Setups

Setup for RF Signal Generation
1. Start the RFXpress installed on the AWG.

2. From the toolbar, select the signal type as IF/RF.

3. Make connections as shown in the figure:

Connect the AWG Ch 1 Analog Output to the DUT where the RF Signal must be fed.

When using the Interleave mode, the RF output should be taken from Interleave Output as shown.

4. Click Compile. The waveform is compiled according to the default settings in the Compile Settings
window. The compiled waveform is displayed in the Waveform List. This IF/RF waveform will be
transferred to the AWG channel (Ch1) and this can also be seen in the Instrument Control > AWG tab.

5. Click On/Off to turn on the channel Ch1.

6. Click Run to generate the signal on the AWG.

See also:

Calibration
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Getting Started Setup for IF Signal Generation

Find Instruments

Setup for IF Signal Generation
1. Start the RFXpress installed on the AWG.

2. From the toolbar, select the signal type as IF/RF.

3. Connect the AWG Ch 1 Analog Output to the DUT where the IF Signal must be fed.

4. Click Compile. The waveform is compiled according to the default settings in the Compile Settings
window. The compiled waveform is displayed in the Waveform List. This IF waveform will be
transferred to the AWG channels (Ch1) and this can also be seen in the Instrument Control > AWG tab.

5. Click On/Off to turn on the channel Ch1.

6. Click Run to generate the signal on the AWG.

See also:

Calibration

Find Instruments

Setup for AWG IQ Signal Generation
1. Start the RFXpress installed on the AWG.

2. From the toolbar, select the signal type as IQ.

3. Make connections as shown in the figure:

Connect the AWG Ch1 Analog Output to the DUT where the I Signal must be fed.

Connect the AWG Ch2 Analog Output to the DUT where the Q Signal must be fed.
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Getting Started Setup for AWG IQ Signal Generation

NOTE. Both cables must be the same length, otherwise you would need to deskew them.

4. Click Compile. The waveform is compiled according to the default settings in the Compile Settings.
The compiled waveform is displayed in the Waveform List. This waveform will be transferred to the
AWG channels (Ch1 and Ch2). This can also be seen in the Instrument Control > AWG tab.

5. Click On/Off to turn on the channels Ch1 and Ch2.

6. Click Run to generate the signal on the AWG.

Setup for AWG IQ Signal Generation with External Modulator
1. Start the RFXpress installed on the AWG.

2. Select the Signal type as IQ.

3. Make connections as shown in the figure:

Connect the AWG and Agilent performance signal generator® (E8267D with Option 015) through
LAN or GPIB.

Connect the AWG Ch1 Analog Output to the Agilent performance signal generator’s (PSG®)
external I Input (in the rear panel).

Connect the AWG Ch2 Analog Output to the Agilent performance signal generator’s (PSG®)
external Q Input (in the rear panel).

Connect the PSG’s RF output from the front to the DUT.
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NOTE. Both cables must be the same length, otherwise you would need to deskew them.

4. Click Compile. The waveform is compiled according to the default settings in the Compile Settings
window. The compiled waveform is displayed in the Waveform List. This waveform will be transferred
to the AWG channels (Ch1 and Ch2). This can also be seen in the Instrument Control > AWG tab.

5. Click On/Off to turn on the channels Ch1 and Ch2.

6. Click Run to generate the signal on the AWG.

See also:

Calibration

Find Instruments
Operating Basics

About Basic Operations
The basic operations section describes the software, tells how to start the software, use the menus and
toolbars, and describes the dialog boxes.

In this online help, all menu selections are indicated with Menu name and Menu options separated by
">". You can access a command or a menu option in more than one way. Several main menu options are
available in a toolbar that you can use instead of selecting the option from the main menu. Shortcut menus,
which open with a right-click, are provided for editing, creating and viewing graphs, importing data from a
file or a Tektronix oscilloscope, and transferring a waveform to an arbitrary waveform generator.

Some dialog boxes also have a Help button that displays help for that dialog box.
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Detailed operations and parameters are described in the sections on Generic Signal, UWB-WiMedia,
Calibration for WiMedia Signals, Instrument Control, and Graphing. The References section lists Error
Messages, Shortcut Keys, and provides a note on Interleaving.

The following figure shows the application screen, the menu, the toolbar, and other elements of the
user interface.

Overview of the Software
RFXpress is a software application that creates digitally modulated baseband, IQ, IF, RF, and
UWB-WiMedia signals that can be generated through arbitrary waveform generators (AWG). This
software runs as an integral part of AWG5000 and AWG7000 series arbitrary waveform generators and
can also run from an external PC.

Features of RFXpress
Baseband data generation: Define baseband I and Q signals using a variety of modulation schemes
such as, BPSK, QPSK, PI/4 QPSK, OQPSK, 8-PSK, O-8PSK, QAM16, QAM32, QAM64, QAM128,
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QAM256, QAM256, QAM512, QAM1024, GMSK, 2-FSK, 4-FSK, 8 -FSK, 16-FSK, 32-FSK, AM,
FM, and PM.

Multi-carrier setup: Define multiple RF/IF carriers in a single waveform. Each carrier can be
independently defined with parameters such as carrier frequency, symbol rate, modulation type, and
baseband filters.

IQ impairments: Apply impairments including quadrature error and quadrature imbalance.

Generate the following graphs:

Frequency Domain: Spectrum

I v Q: Constellation

Time Domain: I(t) and Q(t)

Statistical: CCDF

Distortion measurement for system calibration: To maintain system integrity and coherency with
Amplitude, Phase inband flatness, and skew between separate channels. The setup includes capturing
data from a TDS oscilloscope and a real-time spectrum analyzer and downloading the data to generate
the correction data.

Noise/interference generation and addition: Generate and add interference for waveforms. Generate
gated noise on specific frames designated by the user.

Capture and Replay: Waveforms captured from oscilloscopes and real-time spectrum analyzers can
be modified in RFXpress before they are regenerated.

Wrap around: RFXpress completely eliminates all the wrap-around effects found in arbitrary
waveform generators, providing seamless signals that can be played back continuously without any
discontinuity or glitch in the time, frequency, modulation, or channel coding domains.

Connectivity between AWG, oscilloscope, and Agilent Performance Signal Generator® (PSG).
The ability to identify and connect to a Tektronix Arbitrary Signal Generator (AWG), a Tektronix
oscilloscope, and the Agilent PSG®, and to configure their setups remotely.
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Starting the Software
From the Start menu, click All Programs > Tektronix RFXpress > RFXpress. You can also double-click
the RFXpress shortcut on the desktop.

You can use the software in three modes:

RFXpress on any AWG5000 or AWG7000 series instrument. In this case, the software automatically
detects the AWG software. You can transfer data directly to the AWG. The status bar shows
"AWGXXXX Online"

RFXpress on a PC with the AWG software running in the offline mode. In this case, the AWG software
has to started before starting RFXpress. You can transfer data to the AWG offline software. The
status bar shows "AWGXXXX Offline".

NOTE. If RFXpress does not detect the offline version of the AWG software, the following message appears:
AWGMemorymgr.exe is not found.

RFXpress on a PC without the AWG software. In this case, the software does not detect the AWG
software, and you cannot transfer data to the AWG (although you can create and store the waveform
for later use). The status bar shows "AWGXXXX Not Available".

Using the Software to Create a Signal
Using RFXpress, you can generate a signal as follows:

1. Select an application or module: Generic Signal or UWB-WiMedia.

2. Select the signal type: IF/RF or IQ.

3. For a Generic signal, select the number of carriers: Single or Multi-carrier. For a UWB signal, select
the mode: Conformance or Custom.

4. For a Generic signal, define the carrier parameters: Frequency, Modulation, Amplitude, Filter and
others. For a UWB signal, select the setup and define the selected packet group and packet parameters.

5. Select the compilation options and compile the signal.

You can also specify the graphs that you want to create and view them in the Graph Preview window. You
can transfer the signal to an arbitrary waveform generator in the Instrument Control window. Importing
files and replicating waveform files work with only the following instruments:

Oscilloscopes: Tektronix TDS6000, DPO70000, and DPO7000 series

Arbitrary Waveform Generators: Tektronix AWG400, AWG500, AWG600, and AWG700 series

Real-time Spectrum Analyzers: Tektronix RSA3000 and RSA60000 series
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Exiting the Software
Select File > Exit to exit the application. If you have not saved the waveforms, you are prompted to do so.

File Name Extensions and Directories
The software uses the following file name extensions:

Table 3: File name extensions and their descriptions
File name extension Description
.rfs Setup file of the selected application
.rfd Data file of the waveform (generic signal and ultra wide

band signal)
.smp Symbol file
xxx

The software uses the following directories:

Table 4: Directory names and their descriptions
Directory Description
C:\Program Files\Tektronix\RFXpress\System Contains the application files and executables
C:\Program Files\Tektronix\RFXpress\Documentation Contains the related documentation as text and PDF files
C:\Program Files\Tektronix\RFXpress\Samples Contains sample waveform files
xxx
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Applications, Setup Files, and Data Files
An application is a module that you can use to create specific types of waveforms, for example Generic
Signal and UWB-WiMedia. Applications that are available but have not been purchased appear in the
Application list but are disabled.

You can only have one Setup File (.rfs) open at a time and only one application in use at a time. If you
change the application, you will be prompted to save the open file.

Selecting an application: In the Select field, select an application from the list. When you select
an application (Generic Signal or UWB-WiMedia), the default settings are displayed for the currently
selected application.

Setup File (.rfs): A Setup File is a collection of settings that describes a single waveform. Once you
compile the setup file (using Waveform > Compile), you can save the file as a Data File (.rfd). Compiled
data files for the current session appear in the Waveform List. After you select the Application, a default
Setup File opens automatically. If a setup file is open with unsaved changes and you try to create a
new file or change applications, you are prompted to save the file. To open an existing setup file, select
File > Open Setup.

The rfs file content varies depending on the selected application (Generic or UWB-WiMedia). By default,
the name of the rfs file is derived from the application name.

Data File (.rfd): You can save a compiled Setup File as a Data File using File > Save Data or Save Data
As. Files that you import from other instruments become data files. Select File > Save or Save As to save
these data files. To open an existing data file, select File > Open Data.

NOTE. Each rfd file can store one of the three formats: IF/RF, I and Q. An rfd file stores the version information
and sampling rate.

Menus and Toolbars

Menu Bar
The RFXpress menu has the following items:

File

12 RFXpress RFX100 User Manual



Operating Basics Menu Bar

Use the File menu to:

Restore the default setup for the currently active application

Create new waveform setups

Open, close and save waveform setups (.rfs format)

Open, close and save data files (.rfd format)

Import data from a file (created by another software)

Import data from a Tektronix oscilloscope

Exit the software

View

Use the View menu to:

View the Standard toolbar

View the Status toolbar

Configure
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Use the Configure menu to:

Select an application: Generic Signal or UWB-WiMedia (if this option has been purchased)

Open the Find Instruments dialog box to make instrument connections

Waveform

Use the Waveform menu to:

Compile the currently active Waveform Setup

Set Compilation options

Open the Graph Setup dialog box to select the graphs

System
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Use the System menu to:

Run

Stop

Turn all channel outputs on or off

Open the Calibration dialog box and set the parameters to calibrate the signal

Window

Use the Window menu to:

View the Waveform List window

Preview the Graphs

Open Instrument Control window

Open the Overview window

Close all windows

Help
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Use the Help menu to:

Open the online help

Display help specific to the currently active application

Display technical support on the Tektronix Web site

Display information about the application, such as version number

Standard Toolbar
The Standard toolbar is always displayed by default. Select View > Standard toolbar to hide or show
the toolbar.

The Standard toolbar has the following options that you can select:

Select Application

Signal type

Calibration

Overview

Find Instruments

Graph

Compile and Compile Settings
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Status Bar
The Status Bar is always displayed by default. Select View > Status Bar to hide or show the status bar.
The status bar shows the selected application, the AWG mode, and the active waveform names. For
UWB-WiMedia signals, the status of calibration (On/Off) is also displayed.

Waveform List
Window > Waveform List

The Waveform List is a floating window and can be moved anywhere in the display area. By default it
opens in the leftmost area of the display window. The Waveform List window can be kept open by
pushing the pin in the top right corner, or closed and opened as you like. To view the waveform list,
from the menu select Window > Waveform List.

After you select a signal to generate and set the parameters for it, you must compile it to create the data.
Once you compile a signal (using Compile from the toolbar), waveform data is created and added to the
waveform list. The Waveform list displays the Name, Length, Sampling Rate and Format of the waveform
data. The maximum number of waveforms that can be displayed in the waveform list is 100. When the
number of waveforms exceeds this limit, a warning message appears: Number of waveforms is over the
maximum limit of 100.

To save a waveform that is available in the list, select the waveform and select File > Save Data or Save
Data As. You can also right-click the selected waveform and choose Save Data As. The compiled
waveform or data file is saved as a data file (.rfd) in the specified location. The data files are stored in the
path where the application is installed.

NOTE. If you close the software without saving the compiled waveform, the waveform is lost. You can compile
the waveform again from the setup, if you have saved the setup using File > Save Setup or Save Setup As. The
setup file is an rfs file.

You can select the following options from the shortcut menu:
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Table 5: Shortcut menu options and their description
Selection Description
Send to AWG Enabled only if the AWG software is running and when a

waveform is selected. Sends the selected waveform data
to an Arbitrary Waveform Generator. Select the channel to
which to send the data.

Show Graph Enabled only when a waveform is selected. Plots a graph of
the selected type: Frequency Spectrum, Time Domain and
CCDF. You can also select Graph Settings... and choose
the graphs from those available.

Save Data As... Enabled only when a waveform is selected. Saves the
selected waveform data as a .rfd file in the specified name
and location.

Import from File... Imports data into the software from a file. Choose the file
and location from which to import data.

Import from Tektronix Oscilloscope... Imports data from a Tektronix oscilloscope that is connected
to the instrument on which the software is running.

Delete All Enabled only when a waveform or waveforms are available
in the Waveform List. Deletes all the waveforms shown in
the waveform list.

Delete Enabled only when a waveform is selected. Deletes the
selected waveform.

Rename... Enabled only when a waveform is selected. Opens a dialog
box that allows you to enter a waveform name.

xxx

You can also drag and drop a waveform from the Waveform List to Instrument Control. When you drag
and drop a waveform, the sampling rate is automatically set in the instrument.

The Rename…, Save As… and Delete buttons appear at the bottom of the Waveform List. These buttons
are available only when a waveform is selected.
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Table 6: Waveform list buttons and their description
Selection Description
Rename... Opens a dialog box and allows you to rename the selected

waveform.
Save... Saves the selected waveform as an .rfd file.
Delete Deletes the selected waveform.
xxx

Generating Graphs
In the shortcut menu, from the Graph option you can select the following graphs: Time Domain, Spectrum,
and CCDF. Not all the graphs are available for all waveform formats. The following table lists the
availability of the graphs for various waveform formats.

Table 7: Waveform formats and available graphs
GraphsSelected waveform

format CCDF Spectrum Time Domain
When both I and Q
waveforms are selected

Available Available Not available

When I waveform is
selected

Not available Not available Available

When Q waveform is
selected

Not available Not available Available

When IF/RF waveform is
selected

Not available Available Available

xxx
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Toolbar Options

Select Application
Configure > Select Application

Before you create a new Waveform Setup and Setup File, you must identify the application. Do this by
clicking on the Application field and selecting either Generic Signal or UWB-WiMedia. The default
settings for the currently selected application will be displayed.

NOTE. UWB-WiMedia is enabled only if you have purchased the option.

Signal Type
Set the signal type from the drop-down list to either IF/RF or IQ. Another way to select the signal type is
by using the Compile Settings dialog box.

Compile
Waveform > Compile

To compile a currently active waveform:

1. Click Compile in the Standard toolbar. The waveform is compiled and displayed in the Waveform List.

2. From the Waveform List, you can select Send to AWG, Show Graph, Save Data as, Delete, or Rename
the waveform.
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On/Off

Click the On/Off button to turn on or turn off the arbitrary waveform generator (AWG)
channel output.

Run

Click the Run button to turn on or turn off the Run state of the arbitrary waveform generator
(AWG). If the application is running on an AWG or using an offline mode of the AWG software, the
compiled waveform is directly output to the channel. The channel is turned on and generates the signal.
The signal generation is indicated when the Run button changes to green.
Dialog Boxes

Open Setup
File > Open Setup

You can open a setup file from the selected location. All files have the file name extension .rfs.

Open Data
File > Open Data

You can open a data file from the selected location. All files have the file name extension: .rfd.

Save Setup
File > Save Setup, File > Save Setup As...

You can save the setup file in any of the following formats: .rfs and .txt.

Use File > Save Setup to save an existing setup file with the same name. If you are saving the setup for the
first time, the Save Setup option works exactly as the Save Setup As... option.

Use File > Save Setup As... to save the setup file with another file name.
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Save Data
File > Save Data, File > Save Data As...

You can save the data file in either .rfd or .txt format. You must compile a setup before you can save the
data. If you try to save a setup as data without compiling, you are prompted to compile the setup.

Use File > Save Data to save an existing data file with the same name. If you are saving the data for the
first time, the Save Data option works exactly as the Save Data As... option.

Use File > Save Data As... to save the data file with another file name.

Import Data from a File
File > Import from File

You can import a waveform file created in another software, and import the resulting waveform into
RFXpress. To import data from a file, select File > Import from file. This dialog box is displayed. Navigate
to the directory of choice and select the file to import.
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You can import files of the following types:

.wfm from oscilloscopes and arbitrary waveform generators

.iqt from real-time spectrum analyzers (RSA3000 series)

.tiq from real-time spectrum analyzers (RSA6000 series)

.pat from arbitrary waveform generators

.isf from oscilloscopes

.csv (comma separated file)

.txt (text file)
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The following options are available:

Table 8: File import options and their description
Selection Description Default value
Data Type: I Data, Q Data, IF/RF Data Select the data type to specify the type

of data contained in the file. Enabled
only when the file formats are .csv
and .txt

I Data

CSV, Txt Format Specifies the parameters contained in
the csv or text file:
Time, Volt <cr><lf> (TDS CSV format)
Points, Volt <cr><lf>
Volt <cr><lf>
Volt <cr><lf>, AWG710 format
Enabled only when the file format is
.csv or .txt.

Time, Volt <cr><lf> (TDS CSV format)

Overwrite waveform in list When selected, overwrites the
waveform present in the waveform list
without any warning.

Disabled

Set as baseband signal When selected, replaces any existing
carriers with two carriers representing
the baseband signal. This option is
available only when an iqt or tiq file is
selected for import and the selected
application is Generic Signal.

Disabled

xxx

Import from Tektronix Oscilloscope
File > Import from Tektronix Oscilloscope

You can import a waveform file from a Tektronix oscilloscope that is connected to your instrument into
RFXpress. To do this, select File > Import from Tektronix Oscilloscope. This dialog box is displayed.
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A table displays a list of oscilloscopes on the network. Select an oscilloscope in the table and click
Connect to connect to it. You can connect to more than one oscilloscope at a time. Click Disconnect to
disconnect from an oscilloscope.

For a connected oscilloscope, you can set the following parameters:

Table 9: Waveform import options and their description
Selection Description Default value
Data Source Select the data from which to acquire

the waveform data: Ch1 to Ch4,
Math1 to Math4, and Reference1 to
Reference4.

Ch1

Waveform Type Select the type of waveform: I, Q, or
RFIF.

I

Waveform Name Specify the waveform name. The
imported waveform is saved in the
specified name.

N/A

Acquisition Mode Set the acquisition mode to one of
the following: Samples, Peak Detect,
Envelope, or Average.

Samples

Record Length Displays the record length of the
selected oscilloscope. Change the
record length by entering a new value
in the field.

N/A

xxx

Click Acquire to import the data. The specified waveform name is used to list the waveform in the
Waveform List.
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Find Instruments
Configure > Find Instruments

You can find instruments on the network and connect to them.

1. Click Find Instruments to find other instruments on the network. The following dialog box opens. A
table lists the instruments found along with the Name of the instrument, Model, Status (connected or
not), and the Connection type (Ethernet or GPIB).

2. Select an instrument from the table. Use the following buttons to:

Table 10: Find instruments options and their description
Button Description
Connect Connect to the instrument selected in the table. Connect

is enabled by default if an instrument is highlighted in the
table; disabled if no instrument is highlighted.

Disconnect Disconnect the connected instrument. Enabled only if
highlighted instrument is connected.

Refresh Refresh the list of instruments.
Import... Open the Import from Tektronix Oscilloscope dialog box to

select a file to import.
xxx

3. Click Connect to connect to the selected instrument. The Status provides the current status during the
refresh operation: Searching Instruments or Ready.

Graph
Waveform > Show Graph or Graph Settings
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The software allows you to select the types of graphs before creating them. The graphs are displayed in
two modes: as a set in a small window (for preview), and as individual graphs in large independent
windows. At any time, a maximum of three graphs can be displayed in the small view.

To specify the graphs to create, click Graphs in the toolbar or Waveform > Graph from the menu. The
Graph Setup dialog box opens.

Follow these steps to select the graphs to create:

1. Highlight a folder on the left. The graphs are grouped into the following folders: Frequency Domain, I
vs. Q, Statistical, and Time Domain.

2. Highlight a graph from Available Graphs on the right. Click Add to add the graph to the Selected
Graphs area or drag and drop the graph to the Selected Graphs area.

The following folders and graphs are available:

Frequency Domain: Spectrum

I Vs Q: Constellation

Statistical: CCDF and Eye Diagram

Time Domain: I & Q vs. time, and Pulse shape

NOTE. Once three graphs are added to Selected Graphs, the software will not allow you to add any more graphs.
You must remove a graph before you can add another graph.

To remove a graph, highlight a graph in Selected Graphs and click Remove.

3. Click OK to view the graphs. the graphs are displayed in the Graph Preview tab. If you have selected
fewer than three graphs, the other window (or windows) will be empty.

You can also create graphs from the Waveform List as follows:

1. Select a waveform from the Waveform List.

2. Right-click to view the shortcut menu.
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3. Select Show Graph and select the type of graph to generate. The graph is displayed in a large
independent window.

Graph Preview
Graph Preview is a tab in a window that is shared with Instrument Control. Click the Graph Window tab to
open it as a docked window.

When RFXpress first launches, Graph Preview is closed by default. Thereafter, RFXpress will reopen in
the tab in the same state that it was in when you last exited the application.

Large Graph Windows
1. In the Graph Preview tab, click Maximize to view a graph in a larger window. The selected graph is
displayed in a larger window.

NOTE. When no graphs are selected, Maximize is not available.

The Zoom In and Zoom Out buttons are available in the following graphs: Spectrum, and I(t) Q(t)

Cursors, Cursor Readouts and the difference (Delta) between the cursors are available for the following graphs:
Spectrum, I(t) Q(t), and CCDF.

2. Click to close the graph and return to the small view.

Graphs from External Data
You can import data from a file (File > Import from File) and create graphs using the data. The imported
file is displayed in the Waveform List. Select the file from the Waveform List, right-click, and click
Show Graph.
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Compile Settings
Waveform > Compile Settings

To specify compilation settings for the currently active Waveform Setup, click Compile Settings. This
dialog box is displayed.

RFXpress supports generation of two signal types. The number of waveforms generated varies depending
on the signal format selected.

Baseband signals (IQ format): When the IQ signal format is selected, two baseband waveforms I and
Q are generated. You must specify the names of each waveform.

RF signals (IF/RF format): When the RF signal format is selected, the baseband waveforms I and Q are
also generated. So after compiling, three different files are generated.

For example, if the waveform name is Test, the generated waveforms are: Test_I, Test_Q, and Test.
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The Correction Files option is available only when the selected application is UWB-WiMedia and the
Compile Button Prefs option is available only when the AWG software is detected.

Table 11: Compile settings options and their description
Selection Description Range, Default value
Waveform length (Symbols,
Samples) 1

Specifies the time domain length of
the resulting waveform. It can be
expressed in Samples or Symbols.

Determined by the maximum
waveform memory of the instrument.

Automatic Calculates the waveform length
automatically, based on the setup
parameters and the AWG model. To
enter the waveform length, disable
this option.

Enabled

Correction Files
When compiling apply correction files
to these channels: Ch1, Ch2, Ch3,
Ch4

Available and enabled for each
channel on the instrument. For
two-channel instruments, only Ch1
and Ch2 are visible. When a channel
is selected, the corrections are applied
from the file during compilation. If
no file exists, you are prompted to
either create a correction file in the
Calibration window, or compile without
applying correction files.

Disabled

Signal Format
IF/RF Sets the signal format to IF/RF. N/A
IQ Sets the signal format to IQ. N/A
Oversampling 2 Specify the oversampling value. Automatic
Automatic Calculates the oversampling

automatically, based on the setup
parameters and the AWG model. To
enter the oversampling value, disable
this option.

Enabled

RF Waveform Name Enter the name of the waveform to be
generated after compilation. Uses the
name entered here for the generated
RF waveform.

Waveform1

I Waveform Name Enter the name of the I waveform
to be generated after compilation.
Uses the name entered here for the
generated I waveform.

Waveform1_I

Q Waveform Name Enter the name of the Q waveform
to be generated after compilation.
Uses the name entered here for the
generated Q waveform.

Waveform1_Q

Compile Button Prefs
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Table 11: Compile settings options and their description (cont.)

Selection Description Range, Default value
Compiles and sends to Compiles the currently active

waveform setup and sends it to the
specified channel.

Ch1

Compile only Compiles the currently active
waveform setup.

N/A

Normalization
Mode Select the normalization mode from

the following: Auto, Manual.
You can normalize a waveform such
that all points on it lie between +1 and
–1.

Auto

Division factor Enabled when the Normalization
Mode is Manual. Specify the division
factor to use to divide the waveform
values.

0.01 to 100, 1

Adjust for Wrap-Around When selected, adjusts the waveform
for wrap around during oversampling.
When cleared, the following message
appears: The signal generated from
the AWG might have wrap-around
artifacts in continuous mode.

Enabled

Overwrite waveform in list When selected, overwrites any
existing waveform of the same name
in the waveform list. When this option
is disabled, you are prompted to enter
a waveform file name.

Enabled

xxx

1 If the Waveform Length is expressed in symbols, the number of samples is approximately given by the product of the number of symbols and the
sampling rate divided by the symbol rate.

2 For IF/RF signals, the sampling rate is approximately the product of the maximum carrier frequency and the oversampling. For IQ signals, the
sampling rate is approximately the product of the anchor carrier symbol rate and the oversampling. For UWB-WiMedia signals, sampling rate is
approximately the product of the highest band group centre frequency and the oversampling.

Click Compile to compile the waveform. A progress bar is displayed during compilation. You can abort
the compilation by clicking Cancel.

NOTE. When Adjust for Wrap-Around is enabled and the waveform length is set in samples, the symbol rate of the
compiled waveform may be close to, and not exactly the same as, the value specified in the Setup tab. Similarly,
when the waveform length is set in symbols, the carrier frequency of the compiled waveform may be close to, and not
exactly the same as, the value specified in the Setup tab.
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Option Installation
System > Option Installation...

You can use the RFXpress application to generate waveforms but you cannot transfer the waveform unless
you enable the function with a option (license) key.

Click System > Option Installation.... This dialog box is displayed.

Table 12: Option installation information and their description
Selection Description
User Name Enter the user name.
Serial Number Enter the serial number that is provided along with the

software.
Option Key String Enter the option key string that is provided along with the

software.
Option Information The option information is displayed in the table.
xxx

Click Copy Option Info to copy the information in the table to the clipboard. Click Apply to apply the
entered values.
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Overview
Window > Overview

Click Window > Overview to open the overview window. A block view of the active waveform appears
in a new window. This window is a floating window and can be moved around the screen. Each larger
grouping in the diagram corresponds to a tab.

For a Generic Signal, you must select a carrier before you select the Overview option. The Overview
window for a carrier has the following blocks:

Setup includes Base Data, Modulation, and Filter/Window

Power Ramping

I/Q Impairments includes Carrier Leakage, Nonlinear Distortions, Quad Error, and I/Q Imbalance
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Distortion Addition includes Amplifier Distortion

Multi-Path includes Define Path

Interference Addition includes Signal addition, Offset, and Sinusoidal Interference

Hardware Skew

NOTE. When no carriers are selected in the Carrier table, selecting Overview will open the Overview Window with all
the On/Off buttons set to Off (default). Clicking the On/Off buttons will not have any effect.

For a UWB Signal, you must select a packet group before you select the Overview option. The Overview
window has the following blocks:

Setup includes Packet Group, Packet Definitions, and Hopping

I/Q Impairments includes Carrier Leakage, Quad Error, I/Q Imbalance, and Nonlinear Distortions

Distortion Addition includes Amplifier Distortion

Multi-Path includes Define Path

Interference Addition includes Signal Addition, Offset, Gated Noise, Sinusoidal Interference, and
Real World Signal

Hardware Skew

The On/Off button in the upper right corner of each block in a block corresponds to the Turn On check
box in the appropriate group.

34 RFXpress RFX100 User Manual



Operating Basics PRBS Editor

If the group does not have a Turn On check box, then no On/Off button appears on the block.

If the check box is cleared, the button text is Off (red), and the block appears dimmed.

If the check box is selected, the button text is On (green) and the block appears active. The button on
the block and the check box in the group box are linked—if you change one, the change is reflected in
the other. The on/off values for each block correspond to the currently selected carrier or packet group.

Clicking a block (even if dimmed) brings the File window forward with the corresponding tab at front.
Within the tab, the first setting in the group box that corresponds to the block is highlighted.

To turn on or turn off the calibration corrections, click Configure > Calibration.
Generic Signal Dialog Boxes

PRBS Editor
This dialog box is displayed upon clicking PRBS Editor when PRBS is set to User-defined in the Base
Data field (Setup tab).

This data source can generate different pseudo-random binary sequences. You can select PRBS 7, PRBS 9,
PRBS 15, PRBS 16, PRBS 20, PRBS 21 and PRBS 23 in the field to the right of the PRBS button.

PRBS sequences are generated by a feedback shift register. The number (#) following PRBS indicates the
length of the generating shift register. For instance, a shift register with 16 memory cells is required to
generate a PRBS 16 sequence. The pseudo-random sequence of a PRBS generator is determined by the
number of registers and the feedback.
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Table 13: PRBS editor options and their description
Selection Description Default value
Use different PRBS at beginning of segment When selected, allows you to define a PRBS

polynomial expression. The polynomial that
you define will be used at the beginning of
every sequence. The value of X ranges
between 1 and 31.

Disabled

Initial PRBS polynomial expression Enter an expression in the format
Xn1+Xn2+1 to add to the initial part of the
PRBS polynomial expression. The value of
Xn ranges between 1 and 31. Enabled when
Use different PRBS at beginning of segment
is disabled.

X31+X30+1

PRBS polynomial expression Enter an expression in the format
Xn1+Xn2+1 to generate the pseudo-random
sequence. The value of Xn ranges between
1 and 31.

X31+X30+1

Shift register initial value D1– D31 Enter values in the shift registers to create
the sequence. The registers D1 through D31
can take the values 0 and 1.

D1– D31

xxx

Click Apply to effect the changes. Click Reset to Default to restore the editor to the default values. Refer
to the Appendix for more information on the the taps and the seed (starting values).

See also:

PRBS Editor Starting Values

Data Source Values
This dialog box is displayed when you set the Base Data selection to File and browse for the file. The file
formats supported are .txt and .dat. Once you select a file, the data values are taken from that file.

The following conditions must be met for a valid file:

Any ASCII file, delimited or not, can be used as the data source.

The next bit will be generated by reading the file until a 0, 1, x, or X character is found. 0 and 1 will
add the corresponding bit to the sequence; the x and X character will add a new random bit.

Any other intermediate character will be ignored.

When the end of the file has been reached, the file is read again from the beginning based on the
Record Length.

The data can be organized by columns or rows.

Any number of space, tab, or comma characters can be used as a delimiter.

Empty lines or invalid lines at the beginning and end of the file are ignored.
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Modulation File1(Samples)
This dialog box is displayed when File1(Samples) is selected in the Modulation field (Setup tab).

Table 14: Modulation File1(Samples) options and their description
Selection Description Default value
External Select External to specify an external file taken from a specified

path.
External

Internal Select Internal to specify a file to be taken from the Waveform
List. Click the icon next to the File field and a list of waveforms
appears.

N/A

File Select the modulation file to be used by entering the path or
browsing to the file. The file formats supported are: .txt, .dat,
and .bin.

N/A

Data Org Specify the organization of data within the selected file: I/Q, Q/I, I
Only, or Q Only. When Internal is selected, the available options
are I Only and Q Only.

I Only

Format Specify the format of the selected file: ASCII, Binary(float), or
Binary(double). This option is not available when External is
selected.

ASCII

xxx

The Data Org field is used to indicate the organization of data as follows within the selected file:

I/Q: The first value of data (until a delimiter) read is considered as I and the next as Q. This will
continue to the end of the file.

Q/I : The first value of data read (until a delimiter) is considered as Q and the next as I. This will
continue to the end of the file.

I Only: All the data read are considered as I, and Q is assigned to zero.

Q Only: All the data read are considered as Q, and I is assigned to zero.

NOTE. If you have defined different files for the I and Q components, then you must define two carriers in the list with
the same basic parameters and select the corresponding component in the Data Organization field.
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The Format field is used to specify the file format. The following conditions must be met for a selected
file format:

When the file format is ASCII, the data should be in floating point precision. Spaces and tabs are
ignored. Any other characters are considered invalid. RFXpress stops reading data when it encounters
invalid data.

When the file format is Binary(float), the data should be in binary format with floating point precision.

When the file format is Binary(double), the data should be in binary format with double point precision.

When the end of the file has been reached, the file is read again from the beginning, based on the Record
Length.

NOTE. The external file should contain signals with average power of 1 Vrms. You should scale the data appropriately
to ensure that the file contains signals with an average power of 1 Vrms.

Modulation File2(Symbols)
This dialog box is displayed when File2(Symbols) is selected in the Modulation field (Setup tab).

Table 15: Modulation File2(Symbols) options and their description
Selection Description Default value
File Select the modulation file to be used by entering the path or

browsing to the file. The file formats supported are: .txt, .dat,
and .bin

N/A

Data Org Specify the organization of data within the selected file: I/Q, Q/I,
I Only, or Q Only

I Only

Format Specify the format of the selected file: ASCII, Binary(float), or
Binary(double)

ASCII

xxx

The Data Org field is used to indicate the organization of data as follows within the selected file:

I/Q: The first value of data read (until a delimiter) is considered as I and the next as Q. This will
continue to the end of the file.
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Q/I : The first value of data read (until a delimiter) is considered as Q and the next as I. This will
continue to the end of the file.

I Only: All the data read are considered as I, and Q is assigned to zero.

Q Only: All the data read are considered as Q, and I is assigned to zero.

NOTE. If you have defined different files for the I and Q components, then you must define two carriers in the list with
the same basic parameters and select the corresponding component in the Data Organization field.

The Format field is used to specify the file format. The following conditions must be met for a selected
file format:

When the file format is ASCII, the data should be in floating point precision. Spaces and tabs are
ignored. Any other characters are considered invalid. RFXpress stops reading data when it encounters
invalid data.

When the file format is Binary(float), the data should be in binary format with floating point precision.

When the file format is Binary(double), the data should be in binary format with double point precision.

When the end of the file has been reached, the file is read again from the beginning, based on the Record
Length.

NOTE. The external file should contain signals with average power of 1 Vrms. You should scale the data appropriately
to ensure that the file contains signals with an average power of 1 Vrms.

Symbol Map
This dialog box is displayed when File3(Map) is selected in the Modulation field (Setup tab).
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Use the symbol map editor to create user-defined modulation schemes. The Symbol Map created is stored
in a binary format. This is useful for unsupported modulation schemes and to introduce impairments
with the simulated waveform.

Table 16: Symbol map options and their description
Selection Description Range, Default value
Total symbols Displays the total number of symbols

entered.
2 to 512, 4

Modulation mode Select the modulation mode: Normal,
Diff (Continuous), Diff (Alternate).
Sets the selected modulation mode.

Normal

Rotation angle Specify the rotation angle between I
and Q.

–180° to +180°, 0°

Offset modulation Indicates whether to apply offset
modulation or not: Yes, No. Selecting
Yes applies offset modulation.

No

Predefined map Causes a dropdown list to appear with
the following selections: None, BPSK,
QPSK, QAM16, QAM32, QAM64,
QAM128, and QAM256.

QPSK

Add/Edit Symbols
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Table 16: Symbol map options and their description (cont.)

Selection Description Range, Default value
I component Specify the I component of the

modulation.
–100 to +100, 1

Q component Specify the Q component of the
modulation.

–100 to +100, 1

Magnitude 1 Specify the magnitude of the
modulation.

0 to 141.421, 1.414214

Phase 1 Specify the phase of the modulation. –180° to +180°, 45°
Map - Settings apply to all symbols
Offset I Specify the offset for the I component. –100 to +100, 0
Offset Q Specify the offset for the Q component. –100 to +100, 0
Rotation I/Q phase Specify the phase rotation between I

and Q.
–180° to +180°, 0°

Scale I axis (%) Specify the scale factor for the I
component.

0% to 500%, 100%

Scale Q axis (%) Specify the scale factor for the Q
component.

0% to 500%, 100%

xxx

1 The Magnitude and Phase parameters depend on the value of the I and Q components. If you change the value of the I and Q components, the
Magnitude and Phase values are recalculated and updated. Similarly, if you change the Magnitude and Phase values, the values of the I and Q
components are recalculated and updated.

Clicking Apply Offset, Apply Rotation, and Apply Phase applies the values to the Map Settings
parameters. The table is updated according to the newly applied values.

The following buttons work as listed:

Table 17: Symbol map buttons and their description
Selection Description
Circle... Defines a circular constellation with equal magnitude.

Opens a dialog box with the following parameters: Number
of Symbols, Radius, Phase offset.

Add Adds I, Q, Magnitude, and Phase values to the table.
Update Updates the selected row from the table.
Delete Deletes the selected row from the table.
Default Settings Clears all the symbol map information and resets to default

values. This is equivalent to opening the Symbol Map
dialog box.

Preview... Previews the table values as a plot.
Load Loads a previously saved symbol file (.smp) and displays

the values in the fields.
Save As Saves all the parameters in a user-specified file (.smp) and

location.
xxx
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Circle
Click Circle to define a constellation window that allows you to create equally spaced symbols in a
circle of a specified radius. You can define an offset angle to rotate the constellation. The Circle dialog
box has the following options:

Table 18: Circle options and their description
Selection Description Range, Default
Number of symbols Enter the number of symbols to use

while creating the constellation.
2 to 512, 4

Radius Enter the radius of the circle. –5.0 to +5.0, 1
Phase offset Enter the phase offset. –180° to +180°, 0°
Reset Phase Offset
0 degrees Select this option to set the phase

offset to zero.
Press Reset to set the phase to 0
degrees.

Selected

Half the angle between consecutive
signals

Select this option to set the phase
offset to half the angle between
consecutive signals.
Press Reset to set the phase to
half the angle between consecutive
signals.

N/A

Reset Resets the phase offset to 0 or 90
depending on the selected phase
offset.

N/A

xxx

NOTE. The external file should contain signals with average power of 1 Vrms. You should scale the data appropriately
to ensure that the file contains signals with an average power of 1 Vrms.

UWB-WiMedia D ialog Boxes

Calibration
Configure > Calibration

To calibrate the signal, click Configure > Calibration. A set of parameters called Calibration Settings are
common across channels. Channel-specific settings are provided in each channel tab. This dialog box is
displayed. The calibration settings are as follows:
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Table 19: Instrument setup option and description
Selection Description Default value
Instrument Setup
Signal Type Select the signal type for calibration: RF, IF IF
xxx

The table displays a list of instruments on the network. The instrument model, status, connection type, and
instrument name (alias) are shown but they are not editable. The following buttons are available:

Table 20: Instrument setup buttons and their description
Button Description
Connect Connects to the instrument selected in the table and updates the status to Connected in

the table.
Disconnect Disconnects to the instrument selected in the table and updates the status in the table.
Test Connection Returns the current status of the instrument selected in the table and displays the status as

Connected (in green) or Not Connected (in red).
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Table 20: Instrument setup buttons and their description (cont.)
xxx

The Calibration Settings and Channel-specific settings are as follows. All the calibration settings that are
set in RFXpress are updated on the connected instrument.

Table 21: Instrument setup options and their description
Selection Description Range, Default value
Calibration Setup
Sample rate (samples/sec) Displays the sampling rate of the

instrument. If you change the
sampling rate, the same is updated in
the instrument.

N/A

Interleave Enabled if the signal type is either RF
or IF.

N/A

Zeroing Enabled only when Interleave is
available on the instrument.

N/A

Band Group Select the band group of the signal
from the following options: User
defined, BandGroup1, BandGroup2,
BandGroup3, BandGroup4,
BandGroup5, and BandGroup6.
For direct RF generation, the
available options are: User Defined,
BandGroup1 and BandGroup2.

BandGroup1

Calibration Reminder Select a reminder to create calibration
files periodically: Once a day, Once a
week, Once a month, and Never.

Never

Average (iterations) Enter the number of times the software
sends and captures the signal through
the user-defined configuration to
create an average.

1 to 100, 10

Generator Center Freq (MHz) Enter the center frequency for the
generated signal. This should
be same as Band Group Center
Frequency when the signal type is RF.
Enabled only for signal type IF with
the range of 800 MHz to 10 GHz. Not
available for signal types RF and IQ.

N/A

Bandgroup Center Freq (MHz) Enter the center frequency for the
user-defined band group. Enabled
only when BandGroup is set to
User-Defined for RF and IQ signals in
the range of 500 KHz to 10 GHz and
for IF signals in the range of 1GHz to
20 GHz.

N/A
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Table 21: Instrument setup options and their description (cont.)

Selection Description Range, Default value
Sideband: Lower, Upper Set the sideband value to the lower

or the upper limit. Enabled only for IF
signals.

Lower

When compiling, apply corrections to
these channels: Ch1, Ch2, Ch3, Ch4
Bands: Band1, Band2, Band3

Applies corrections to the selected
channels and bands (within the
selected BandGroup) when you click
Compile. If the corrections file is not
found, you are warned. However,
you can continue without applying
calibration.

N/A

Channel-specific parameters
Amplitude (Vpp) Displays the amplitude of the channel.

To change it, set a new value for the
amplitude.

N/A

Offset (V) Displays the offset of the channel.
To change it, set a new value for the
offset.

N/A

Use the same amplitude and offset for
all channels

Uses the amplitude and offset set for
a channel for all available channels.

N/A

Select the Correction file Specify the correction file to create.
The correction file that you specify will
be used when you compile the signal.

N/A

xxx

Click Calibrate to create the correction files. The correction file that is created can be used to pre-distort
the signal so that the final signal that is generated is an ideal signal.

Click OK to set the correction file and parameters that will be used during compile. In Compile Settings
if the option "When compiling apply correction files to these channels" is selected, the correction file
specified in the Calibration dialog box is used to apply corrections.

NOTE. Interleave and Zeroing are available only on the AWG7000 series of instruments with Option 06.

Marker Mapping
This dialog box is displayed when you click Marker Mapping... in the Setup tab (UWB-WiMedia) in both
Custom and Conformance modes. The markers M1 and M2 are tightly coupled to the band ID. Marker
mapping is used to provide hopping information to the external RF hopper. The marker information
will be transferred along with IF/RF, I, and Q data. You can use marker information from any channel
where analog data is generated.
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You can set the following options for markers M1 and M2. The marker pattern generated, based on the
following settings, can be used for triggering an external device.

Table 22: Marker mapping options and their description
Selection M1, M2 Description Default value
Band 1 Enter M1 and M2 values. The values

can be 0 or 1
Sets the marker pattern for Band 1 0, 1

Band 2 Enter M1 and M2 values. The values
can be 0 or 1

Sets the marker pattern for Band 2 1, 0

Band 3 Enter M1 and M2 values. The values
can be 0 or 1

Sets the marker pattern for Band 3 1, 1

Marker delay (ns) N/A Enter the marker delay in
nanoseconds. It defines the
delay in marker transition with
respect to the symbols.

Range: –312.5 to
+ 312.5 ns
Default: 0.0 ns

xxx

NOTE. The Marker Mapping dialog box shows a warning message when the AWG is set with 10-bit DAC resolution.
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Tone Nulling
This dialog box is displayed when you click Tone Nulling... in the Setup tab (UWB-WiMedia) in both
Custom and Conformance modes. For the selected Band Group, the tone nulling table shows the carrier
number, the amplitudes, and the phases of Band 1, Band 2, and Band 3 in dB. The amplitude and phase
fields are editable. Double-click the field and enter a new amplitude for the selected carrier and band.

The amplitude values are relative to the amplitudes specified for each band. The tone nulling value ranges
between –40 dB and +20 dB. For example, if a carrier or tone value is set to –40 dB, the amplitude of
the tone is 40 dB less than that specified for the band to which it belongs. The phase value ranges from
–180 degrees to +180 degrees.

Click Default to restore the band values to their default values.
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Hopping Pattern
This dialog box is displayed when you set the TF Code and click Hopping... in the Setup tab in the Custom
Mode (UWB-WiMedia). The hopping pattern for the selected Band Group and TF Code is displayed. The
X-axis (horizontal) shows Time and the Y-axis (vertical)shows the Center Frequencies for the selected
Band Group. The hopping pattern is not editable.

To customize a hopping pattern, set the TF Code to User Defined. You can define a hopping pattern by
clicking the black squares in each column. This sets the frequency at which a packet is transmitted for
each band in a band group. After you have defined the hopping pattern, assign a TFC number (between
1 to 15) to the pattern and click OK.

Process Preferences
This dialog box is displayed when you click Process Preferences in the Setup tab (UWB-WiMedia) in
the custom mode. The dialog box displays several parameters. In the custom mode, all these parameters
can be set for each PPDU or packet listed in the PPDUs in Group table. The fields corresponding to the
parameters are editable and take either Binary or Hexadecimal values. You can change these values and
use your values when the packet is processed. When the parameters are enabled, the software uses your
values while processing the packet. When the parameters are disabled, the software uses calculated values
while processing the packet.
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Table 23: Process preferences and their description
Selection Description Default value
FCS If selected, processes the FCS value

set in the field. If cleared, the default
value for FCS value is used.

Enabled

HCS If selected, processes the HCS value
set in the field. If cleared, the default
value for HCS value is used.

Enabled

Reed-Solomon If selected, processes the
Reed-Solomon value set in the
field. If cleared, the default value for
Reed-Solomon value is used.

Enabled

PHY header tail bits If selected, processes the PHY header
tail bits value set in the field. If cleared,
the default value for PHY header tail
bits is used.

Enabled

Pad bits If selected, processes the Pad tail bits
value set in the field. If cleared, the
default value for Pad bits is used.

Enabled

FCS tail bits If selected, processes the FCS header
tail bits value set in the field. If cleared,
the default value for FCS header tail
bits is used.

Enabled

HCS tail bits If selected, processes the HCS tail
bits value set in the field. If cleared,
the default value for HCS header tail
bits is used.

Enabled
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Table 23: Process preferences and their description (cont.)

Selection Description Default value
Reed-Solomon tail bits If selected, processes the

Reed-Solomon tail bits value set
in the field. If cleared, the default
value for Reed-Solomon tail bits is
used.

Enabled

Reserved bits If selected, processes the Reserved
bits value set in the field. If cleared,
the default value for Reserved bits
value is used.

Enabled

xxx

When you click Process This Packet in the custom mode, the software processes the packet and displays
the output in the fields.

Custom Settings
This dialog box is displayed when you click Rate (Selected PPDU Details) in the Setup tab
(UWB-WiMedia) in the Custom mode. It displays the custom settings that directly affect the data rate
of the selected PPDU.

The settings in the custom mode are as follows:

Table 24: Custom settings and their description
Selection Description Default value
Modulation Select the modulation to QPSK or

DCM.
QPSK
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Table 24: Custom settings and their description (cont.)

Selection Description Default value
Convolution encoder Select the convolution encoder and

set it to one of the following selections:
1/3, 1/2, 5/8, 3/4.

Enabled, 5/8

Interleaver Select or clear interleaver. Enabled
Conjugate symmetry Select or clear conjugate symmetry. Disabled
Time domain spreading Select or clear time domain spreading. Enabled
xxx

The following table lists the PSDU data rate-dependent modulation parameters.

Table 25: PSDU data rate-dependent modulation parameters
Data Rate (Mb/s) Modulation Coding rate Conjugate

symmetry
TDS

53.3 QPSK 1/3 Yes Yes
80 QPSK 1/2 Yes Yes
106.7 QPSK 1/3 No Yes
160 QPSK 1/2 No Yes
200 QPSK 5/8 No Yes
320 DCM 1/2 No No
400 DCM 5/8 No No
480 DCM 3/4 No No
xxx

NOTE. If you select one of the standard settings that results in a standard data rate, the MAC for the data rate takes
the bits from the standard. If the setting results in a non-standard data rate, the bit setting will be "11111".
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Frame Payload
This dialog box is displayed when you click Frame Payload (Selected PPDU Details) in the Setup tab
(UWB-WMedia) in the Custom mode.

Table 26: Frame payload options
Selection Description
Source Select the source for the data to be transmitted from the

following selections: WiMedia Spec Example, All 0, All 1,
PRBS 7, PRBS 9, PRBS 15, PRBS 16, PRBS 20, PRBS
21, PRBS 23, and From File.

File Select the file to be used by entering the path or browsing to
the file. Uses the specified file (.txt or .dat) as the source of
data to be transmitted.

Packet Data Length Displays the packet data length. Used along with the
payload data length and the number of packets to calculate
the data to be sent in one packet.

xxx

The following conditions must be met for a valid file:

Any ASCII file, delimited or not, can be used as the data source.

The next bit will be generated by reading the file until a 0, 1, x, or X character is found. 0 and 1 will
add the corresponding bit to the sequence while the x and X character will add a new random bit.

Any other intermediate character will be ignored.

When the end of the file has been reached, the file is read again from the beginning, based on the
Record Length.

The data can be organized in columns or rows.

Any number of space, tab, comma characters can be used as a delimiter.

Empty lines or invalid lines at the beginning and end of the file are ignored.
Creating a Generic Signal
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Setup

Single Carrier
In the Setup tab (Generic Signal) by default, Single Carrier is selected in the Carriers field. A carrier is
displayed in the carrier table and is selected. When Single Carrier is selected, you cannot add another
carrier; you must switch to Multi Carrier to add another carrier.

IF/RF Signal
When the signal type is IF/RF, the table displays the following: Carrier number, Frequency (MHz),
Amplitude (dBm), Symbol rate (MHz), Modulation, Filter, Alpha/B*T parameter, and State (ON by
default).

The Single Carrier group options show Frequency in Hz and Amplitude in dBm in 50-ohm load.

Table 27: Single carrier group options for IF/RF signal
Selection Description Range, Default value
Signal type: IF/RF
Frequency (Hz) Enter the carrier frequency in Hz. Depends on the instrument bandwidth, 10M
Amplitude (dBm) Enter the amplitude of output signal in dB. –100.00 dBm to + 30 dBm, 0
xxx

IQ Signal
When the signal type is IQ, the table displays the following: Carrier number, Offset (MHz), Amplitude
(Vrms), Symbol rate (MHz), Modulation, Filter, Alpha/B*T parameter, and State (ON by default).

The Single Carrier group options show Baseband Offset in Hz and Amplitude in Vrms.

Table 28: Single carrier group options for IQ signal
Selection Description Range, Default value
Signal type: IQ
Baseband Offset (MHz) Enter the carrier frequency offset in Hz. Depends on the instrument bandwidth, 0
Amplitude (Vrms) Enter the amplitude of out put signal in Vrms. 0 to 5 Vrms, 1
xxx

NOTE. None of the items in the shortcut menu are available in the single carrier table.

Multi Carriers
In the Setup tab (Generic Signal), select Multi Carrier in the Carriers field. An anchor carrier is displayed
in the table. To add a carrier, in the Add Carrier field, type the number of carriers to add. The maximum

RFXpress RFX100 User Manual 53



Creating a Generic Signal Multi Carriers

number of carriers you can have in the table is 512. Each row in the table corresponds to one carrier. If you
try to enter more than 512 carriers, you will be reminded that the maximum number of carriers is 512.

A signal must be repeated to obtain a continuous output for AWGs. To avoid discontinuities at the
transition between the end and the beginning of any pair of segments, the application takes care to avoid
all the “wrap-around” artifacts. For a modulated carrier, to have a signal free of wrap-around artifacts, a set
of conditions must be met by the signal:

An integer number of carrier cycles must be available in the segment for any given carrier.

An integer number of symbols must be available in the segment for any given carrier.

In general, it is difficult to meet these criteria for any given set of carriers if the record length in the target
instrument is a finite and integer number. This means that some rounding must be performed. You can
select one of the carriers as an anchor carrier to act as a reference. The application calculates the output
clock (sampling rate) to preserve some of the frequency characteristics of the anchor carrier. If record
length is expressed in samples, the carrier frequency will be preserved. If record length is expressed in
symbols, the symbol rate will be the preserved. The actual clock output will be also influenced by the
maximum carrier frequency in the carrier table and the oversampling factor. The actual values for carrier
frequencies and symbol rates will be shown in the carrier table after compilation.

NOTE. For each carrier, you can define the parameters in each of the tabs: Setup, Power Ramping, I/Q Impairments,
Distortion Addition, Multi-Path, and Interference Addition.

IF/RF Signal
When the signal type is IF/RF, the table displays the following: Carrier number, Frequency (MHz),
Amplitude (dBm), Symbol rate (MHz), Modulation, Filter, Alpha/B*T parameter, and State (ON by
default).

Select the Base Data and set the Amplitude in dBm in 50-ohm load. The Multi Carrier group options
allow you add carriers based on:

Center frequency, where you must provide the Center frequency and Bandwidth.

Range, where you must provide the Base Frequency and Carrier Spacing.

Table 29: Multi carrier group options for IF/RF signal
Selection Description Range, Default value
Signal type: IF/RF
Center
Center Frequency (Hz) Enter the center frequency of the

carrier.
1 Hz to the maximum supported by
the AWG, 50 MHz

Bandwidth (Hz) Enter the bandwidth of the carrier. 1 Hz to the maximum supported by
the AWG, 100 MHz

Range
Base frequency (Hz) Enter the base frequency of the

carriers.
1 Hz to the maximum supported by
the AWG, 10 MHz
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Table 29: Multi carrier group options for IF/RF signal (cont.)

Selection Description Range, Default value
Carrier spacing (Hz) Enter the spacing between carriers. 1 Hz to the maximum supported by

the AWG, 10 MHz
Phase shift Enter the phase shift between the

carriers (degrees). Disabled when
Random is selected.

–180° to +180°, 0°

Random When selected, uses a random phase
shift value.

Disabled

xxx

IQ Signal
When the signal type is IQ, the table displays the following: Carrier number, Offset (MHz), Amplitude
(Vrms), Symbol rate (MHz), Modulation, Filter, Alpha/B*T parameter, and State (ON by default).

Select the Base Data and set the Amplitude in Vrms. The Multi Carrier group options allow you to enter
the Initial Offset (Hz) and Carrier Spacing (Hz).

Table 30: Multi carrier group options for IQ signal
Selection Description Range, Default value
Signal type: IQ
Initial Offset (Hz) Enter the initial offset of the carriers. Depends on the instrument bandwidth
Carrier Spacing (Hz) Enter the frequency spacing between

carriers.
1 Hz to the maximum supported by
the AWG, 10 MHz

xxx

Editing Carrier Details
If you have more than one carrier and you select a carrier in the table, the Multi Carrier options change
to Selected Carrier options. You can set the options for each selected carrier. To edit carrier parameters,
highlight the carrier in the table, and then do one of the following:

The values for all the settings are displayed in the corresponding fields for the selected carrier. As you
change the values in the fields, the new values are committed immediately.

In the table, double-click the parameter that you want to change and directly enter new values. If you
select File1 (samples), File2 (Symbols) or File3 (Maps), the corresponding dialog boxes open for you to
edit the values. Changing the State to ON or OFF includes or excludes the carrier during compilation.

The Add, Delete and Set Anchor buttons work as follows:
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Table 31: Carrier editing options
Selection Description State
Add Adds one or more carriers to the table. All of

the carrier parameters use default states.
Add is always enabled.

Delete Deletes the selected carrier from the table.
Select multiple carriers using the Shift or
Control keys and dragging the pointer. The
carriers are renumbered when you delete a
carrier from within the sequence.

Delete is disabled when an empty row or no
carrier is selected in the table.

Set Anchor Sets the selected carrier as the anchor carrier.
By default, the first carrier in the table is the
anchor carrier.

Set anchor is disabled when an empty row or
no carrier is selected in the table.

xxx

NOTE. When you add more than one carrier at a time, the Setup tab automatically shows options to allow adding
multiple carriers.

If you change from Multi Carrier to Single Carrier, the following message appears: The current anchor
carrier will become the single carrier. Do you want to continue? You can click Continue and make the
anchor carrier the only carrier in the single carrier mode. You can click Cancel to cancel the operation.

Edit operations are available in the shortcut menu (when you right-click on a selected carrier in the table).
The available operations are: Cut, Copy, Paste, Delete, Delete All, and Set Anchor.

Table 32: Editing options in the shortcut menu
Selection Description State
Cut Cuts the current selected row (carrier) and

copies the contents to clipboard.
Enabled when a carrier is selected.

Copy Copies the current selected row (carrier) and
copies the contents to clipboard.

Enabled when a carrier is selected.

Paste Pastes the contents from memory on to the
selected row or carrier (replaces the selected
row).

Enabled only after a cut or copy operation.

Delete Deletes the selected row (carrier). Enabled when a carrier is selected.
Delete All Deletes all the rows (carriers) in the table. Always enabled.
Set Anchor Sets the currently selected row’s frequency as

anchor frequency.
Enabled when a carrier is selected.

xxx
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Selecting the Base Data
Follow these steps to select the base data for a signal:

1. Select the Setup tab.

2. Select a carrier from the table.

3. In the Base Data field, select the data source. The following table lists the choices for the Base Data
field:

Table 33: Multi carrier options for IF/RF signal
Selection Description Default value
Base data Select the data source from the following: All 0, All 1, PRBS, Pattern, File. PRBS
All 0 Sends a sequence of binary 0 symbols. An example is a data sequence

with the length ten {d} = {0, 0, 0, 0, 0, 0, 0, 0, 0, 0}.
N/A

All 1 Sends a sequence of binary 1 symbols. An example is a data sequence
with the length ten {d} = {1, 1, 1, 1, 1, 1, 1, 1, 1, 1}.

N/A

PRBS Select the PRBS type from the following: 7, 9, 15, 16, 20, 21, 23, and
User-defined.
To edit the bit sequence, select User-defined in the PRBS dropdown menu.
This causes the PRBS Editor… button to appear.

9

Pattern Enter a pattern of 0s and 1s up to a maximum of 80 digits in the text field
that appears.

N/A

File Select the base data file to be used by entering the path or browsing to
the file. The supported formats are .txt and .dat.

N/A

xxx

NOTE. If you try to compile the signal without specifying a base data file, the following message appears: RFXpress
cannot compile. You must select a file for base data first or change the selection.

Modulation for Carriers
Follow these steps to select the modulation parameters for a signal:

1. Select the Setup tab.

2. Select a carrier from the table.

3. Set the following modulation parameters:
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Table 34: Modulation options for carriers
Selection Description Range, Default value
Modulation Select a modulation type from the following:

No Mod, QPSK, BPSK,
PI/4 QPSK, OQPSK, 8-PSK, O-8PSK,
QAM-16, QAM-32, QAM-64, QAM-128,
QAM-256, QAM-512, QAM-1024, GMSK,
2-FSK, 4-FSK, 8-FSK, 16-FSK, 32-FSK,
ASK, AM, PM, FM, File1(Samples),
File2(Symbols), and File3(Maps).

No Mod

FSK Peak Deviation (Hz) Enter the FSK peak deviation value. Defined
only when the modulation type is set to FSK.

Depends on the instrument bandwidth,
1000 KHz

ASK Mod Index (%) Enter the ASK modulation index. Defined
only when modulation type is set to ASK.

0 to 200%, 1%

AM Mod Index (%) Enter the AM modulation index. Defined only
when modulation type is set to AM.

0 to 200%, 50%

Phase Deviation
(degrees)

Enter the phase deviation. Defined only
when modulation type is set to PM.

0° to +180°, 10°

Frequency Deviation
(Hz)

Enter the frequency deviation. Defined only
when modulation type is set to FM.

0 KHz to 10 GHz, 100 KHz

Coding Specifies the coding parameter: None,
Gray, Differential, Gray differential, GSM
differential, NADC, TFTS, and MSAT
differential.

None

Symbol rate (Hz) Enter the symbol rate for modulation. Depends on the instrument bandwidth
Default: 1 MHz

xxx

When the Modulation parameter is set to File1 (Samples), Base Data, Coding and Filter parameters are
not available. The Symbol Rate parameter changes to Input File Sample Rate. When the Modulation
parameter is set to File 2 (Symbols), Base Data and Coding parameters are unavailable. When Modulation
is set to AM, FM, or PM, the Symbol Rate parameter changes to Modulating Frequency.

You can edit the Modulation parameters from the table by selecting the values in the dropdown list for
the parameter. If you select File1 (samples), File2 (Symbols), or File3 (Maps), the corresponding dialog
boxes open for you to edit the values.

Filter for Carriers
Follow these steps to select the filter and window parameters for a signal:

1. Select the Setup tab.

2. Select a carrier from the table.

3. Set the following Filter/Window parameters. The Filter/Window parameters are not available when the
modulation type is Amplitude Modulation, Frequency Modulation or Phase Modulation.
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Table 35: Filter options for carriers
Selection Description Range, Default value
Filter Select the filter from the following options:

Rectangular, Raised Cosine, Root Raised
Cosine, Gaussian (Dirac Delta), Gaussian
(Rectangular, Triangular, Edge), User
defined, and No Filter.

No Filter

Alpha/B*T Enabled for Raised Cosine, Root Raised
Cosine, Gaussian, and Gaussian-2.

Raised Cosine: 0.0 to 1, 0.35
Root Raised Cosine: 0.0 to 1, 0.35
Gaussian Filter B*T: 0.1 to 3.0, 0.5

Convolution length
(symbols)

Enter the convolution length. Convolution
length is used to calculate the FIR filters
impulse response. To keep the pulse shape
symmetric, the convolution length has to be
given in odd number.

3 to 201, 21 (odd numbers only)

Window 1 Select the window type from the
following: None, Rectangular, Triangular,
Hamming, Hanning, Blackman, Kaiser,
Blackman-Harris, Exact Blackman, Flat Top,
Tapered Cosine, and Chebyshev Ripple.
Enabled for Raised Cosine, Root Raised
Cosine, Gaussian, Gaussian-2, Triangular,
and Edge.

None

Kaiser Parameter (dB) Enter the Kaiser parameter. Appears only
when Window is set to Kaiser.

1 to 10, 2.2

Chebyshev ripple Enter the Chebyshev Ripple. Appears only
when Window is set to Chebyshev.

10 dB to 80 dB, 40 dB

xxx

1 The window parameter is available only for Chebyshev and Kaiser Windows.

4. When Filter is set to User Defined, a dialog box appears where you can select a file. The supported file
name extensions are .txt, .dat and .bin. The Format field is used to specify the file format. Ensure that
the following conditions are met for a selected file format:

When the file format is ASCII, the data should be in floating point precision. Spaces and tabs
are ignored. Any other characters are considered invalid. RFXpress stops reading data when
it encounters invalid data.

When the file format is Binary(float), the data should be in binary format with floating point
precision.

When the file format is Binary(double), the data should be in binary format with double point
precision.

Filters must be defined with 50 samples per symbol time as the software will take care of resampling
and interpolate these values to the resolution required by any specific settings.

Filter coefficients must be in columns.

You can edit the Filter parameters from the table by selecting the values in the dropdown list for the
parameter.
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Power Ramping

Power Ramping Parameters
Power ramping allows you to define the power ramping profile for the signal to be transmitted.

Follow these steps to define power ramping for a signal:

1. Select the Power Ramping tab.

2. Select a carrier from the table.

3. Select Turn On to include power ramping parameters. (Select Turn On again if you want to exclude
power ramping parameters for the carriers. By default, Turn On is set to off.)

4. Set the following power ramping parameters:

Table 36: Power ramping parameters for carriers
Selection Description Range, Default value
Ramp
Function Select the power ramping function

from the following: None, Linear and
Cosine.

None

Time (secs) Enter the duration of ramp. 1 ns to 1 sec, 0.1 usec
Position
Symbol Enter the location of the power

ramping.
0 to depends on the instrument model
and option installed , 0

Level / dB Enter the level of the power ramping. –60 dB to +20 dB, 0
Periodically extended power ramping When selected, the time characteristic

of the power ramping is continued
periodically until the end of the signal.

Disabled

xxx

5. Click Add to add the power ramping parameters to the table and Delete to delete the power ramping
parameters from the table. The table contains the Symbol and Level/dB values that you entered.

I/Q Impairments

Carrier Leakage for Single Carrier
Follow these steps to define carrier leakage for a signal:

1. Select the I/Q Impairments tab.

2. Select a carrier from the table.

3. Select Turn On to include carrier leakage (I and Q) impairments to the carrier. (Select Turn On again if
you want to exclude carrier leakage (I and Q) impairments. By default, Turn On is set to off.)

4. Set the carrier leakage for I and Q modulator signal in percentage.
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Table 37: Carrier leakage parameters for carriers
Selection Description Range, Default value
I (%) Enter the carrier leakage for the I

signal.
–50% to +50%, 0%

Q (%) Enter the carrier leakage for the Q
signal.

–50% to +50%, 0%

xxx

Quadrature Error for Carriers
Quadrature Error allows you to control the phase angle between the I and Q signals. Follow these steps
to define quadrature error for a signal:

1. Select the I/Q Impairments tab.

2. Select a carrier from the table.

3. Select Turn On to include quadrature error for the carrier. (Select Turn On again if you want to exclude
quadrature error. By default, Turn On is set to off.)

4. Quadrature error is defined in degrees. A positive value indicates that the phase angle is greater than 90
degrees. Set the following parameter:

Table 38: Quadrature error parameters for carriers
Selection Description Range, Default value
Degrees Enter the phase angle between the I

and Q signals.
–30° to +30°, 0°

xxx
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I/Q Imbalance for Carriers
I/Q Imbalance allows you to create gain imbalance between I and Q. Follow these steps to define I/Q
imbalance for a signal:

1. Select the I/Q Impairments tab.

2. Select a carrier from the table.

3. Select Turn On to include I/Q imbalance for the carrier. (Select Turn On again if you want to exclude
I/Q imbalance. By default, Turn On is set to off.)

4. I/Q imbalance is defined in percentage. Set the following parameter:

Table 39: I/Q imbalance parameters for carriers
Selection Description Range, Default value
Percentage Enter the imbalance between the I

and Q signals.
–30% to +30%, 0%

xxx
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Non-Linear Distortions for Carriers
Non-linear Distortions allow you to simulate the non-linearity of IQ modulators. Follow these steps to
define non-linear distortions for a signal:

1. Select the I/Q Impairments tab.

2. Select a carrier from the table.

3. Select Turn On to include non-linear distortions for the carrier. (Select Turn On again if you want to
exclude non-linear distortions. By default, Turn On is set to off.)

4. Set the following AM/AM and AM/PM parameters:

The variation of the signal amplitude with respect to the original amplitude is called AM/AM conversion.

Table 40: AM/AM parameters for carriers
Selection Description Range, Default value
k2 dB Enter the second order coefficient for the

magnitude.
–3 dB to +3 dB, 0 dB

k3 dB Enter the third order coefficient for the
magnitude.

–3 dB to +3 dB, 0 dB

xxx

The variation of the phase with respect to the original amplitude is called AM/PM conversion.

Table 41: AM/PM parameters for carriers
Selection Description Range, Default value
k2 degrees Enter the second order coefficient for the

phase.
–30° to +30°, 0°

k3 degrees Enter the third order coefficient for the phase. –30° to +30°, 0°
xxx

See also:

Non-Linear Impairments
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Hardware Skew for Carriers
Hardware skew is common for all carriers. The number of channels shown depends on the AWG model
being used. Follow these steps to define hardware skew for a signal:

1. Select the I/Q Impairments tab.

2. Select Turn On to include hardware skew for the carrier. (Select Turn On again if you want to exclude
hardware skew. By default, Turn On is set to off.)

3. Set the following parameters:

Table 42: Hardware skew parameter for carriers
Selection Description Range, Default value
Channel N (ps) Enter a value for each channel.

Adjusting the skew dynamically
updates the dialog box display. The
adjustment applies to analog output
and marker output.

AWG7000: –100 ps to +100 ps, 0 ps
AWG5000: –5 to +5 ns, 0 ns

xxx

Distortion Addition

Amplifier Distortion for Carriers
Amplifier Distortion simulates the non-linearity in the amplifier. You can set the amplifier distortion
to Non-Linear, Hardlimiting, or Softlimiting. Hardlimiting and softlimiting amplifiers affect only the
amplitude of the output signal. The phase of the output signal is not affected.

Follow these steps to define amplifier distortion for a signal:

1. Select the Distortion Addition tab.

2. Select a carrier from the table.

3. Select Turn On to include amplifier distortion for the carrier. (Select Turn On again if you want to
exclude amplifier distortion. By default, Turn On is disabled.)

4. Set the following parameters:

Table 43: Amplifier distortion parameters for carriers
Selection Description Range, Default value
Amplifier Select the amplifier distortion from the following: Non-Linear,

Hardlimiting, and Softlimiting.
Non-Linear

Operating point Enter the operating point of the nonlinear amplifier. 0.01 to 1000, 0.01
Limiting Level Enter the limiting level for the Hardlimiting and Softlimiting

amplifiers.
0.1 to 1000, 0.1

xxx

The following AM/AM parameters are available for a non-linear amplifier:
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Table 44: AM/AM parameters for amplifier distortion
Selection Description Range, Default value
k3 (dB) Enter the third order coefficient for the magnitude. –3 dB to +3 dB, 0 dB
k5 (dB) Enter the fifth order coefficient for the magnitude. –3 dB to +3 dB, 0 dB
xxx

The following AM/PM parameters are available for a non-linear amplifier:

Table 45: AM/PM parameters for amplifier distortion
Selection Description Range, Default value
k3 (degrees) Enter the third order coefficient for the phase. –30° to +30°, 0°
k5 (degrees) Enter the fifth order coefficient for the phase. –30° to +30°, 0°
xxx

See also:

Amplifier Distortions
MultiPath

Multipath Parameters for Carriers
Follow these steps to set multipath parameters for a signal:

1. Select the Multi-Path tab.

2. Select a carrier from the table.

3. Select Turn On to define the path for the carrier. (Select Turn On again if you want to exclude multipath
parameters. By default, Turn On is disabled..)

4. Set the following parameters:

Table 46: Multipath parameters for carriers
Selection Description Range, Default value
Delay (symbols) Enter the delay in symbols from the

reference path. The delay can be
positive or negative. The delay values
cannot be repeated.

–80 to +80 symbols, 0 symbols

Amplitude (dB) Enter the amplitude in dB from the
reference path. The amplitude is
always negative.

–60 to 0 dB, 0 dB

Phase (deg) Enter the phase in degrees from the
reference path. The phase can be
positive or negative.

–180 to +180 degrees, 0 degree

xxx

5. Click Add to add the parameters to the table. Select one or more rows and click Delete to delete
it from the table.

You can define a maximum of ten multipaths, including the reference path that has the delay, amplitude
and phase values set to zero. You can neither delete the reference path with a delay of 0 symbols nor
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change the delay value. However, you can change the amplitude and phase values. No two paths can
have the same delay value. The table rows are automatically sorted in the ascending order of the delay
value. The table contains the Delay, Amplitude, and Phase that you entered.

Depending on the entered delay value, the application might have to recompute the convolution length.
This happens if convolution length provided is not enough for the given multipaths. In this case, the
following message appears: Convolution length will be adjusted to take care of multipaths. Do you
want to adjust? You can choose to adjust or not adjust the convolution length.

Multi-path is created by applying the right algorithm to the baseband I and Q signals. The application
generates a new complex isolated pulse by convolving the direct isolated pulse and the channel impulse
response (it is a complex impulse response at the baseband level). This implies that to have the right
convolution, the total length of the resulting process must be long enough to accommodate the new
isolated pulse.
Interference Addition

Signal Addition for Carriers
Follow these steps to define signal interference for a signal:

1. Select the Interference Addition tab.

2. Select Turn On to include signal interference for the carrier. (Select Turn On again if you want to
exclude signal interference. By default, Turn On is disabled.)

3. Set the following parameters:

Table 47: Signal addition parameters for carriers
Selection Description Default value
Format
I/Q Specifies the signal format of the file to be added. I/Q
IF/RF Specifies the signal format of the file to be added. N/A
Add Interference via:
Software Specifies that the interference addition will be through software. Software
Hardware Specifies that the interference addition will be through hardware. N/A
Waveform_I Click the icon next to the Waveform_I field and a list of waveforms

appears. Select the I waveform to use.
N/A

Waveform_Q Click the icon next to the Waveform_Q field and a list of waveforms
appears. Select the Q waveform to use.

N/A

Waveform_RF Click the icon next to the Waveform_RF field and a list of waveforms
appears. Select the RF waveform to use.

N/A

xxx

When the Signal format is IQ, two interference channels are required, which means that an
AWG5000 series with four channels is required. If you do not have a 4-channel AWG, the message
appears: AWG has only X channels, cannot send interference data to channel.

When the Signal format is IF/RF, at least one channel should be available for interference, otherwise a
message appears: AWG7101, AWG7102 interleave mode cannot be used.
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4. If you set Add Interference via to Hardware, the interference should go to Ch2 and you need to connect
Ch1 output to Ch2 external signal addition input.

NOTE. The AWG7000 series does not support external signal addition via hardware.

Signal Addition via Software
The following table shows the combinations of the signal you want to generate after compilation and the
interference signal that you want to add.

Table 48: Valid combinations of Signal Addition via Software
Compilation format Add Signal format Remarks
IQ IQ Valid combination.
IF/RF IF/RF Valid combination.
IF/RF IQ Valid combination. I/Q interference signals

will be added before modulation.
IQ IF/RF Not a valid combination.
xxx

Signal Addition via Hardware
The following table shows the combinations of the signal you want to generate after compilation and the
interference signal that you want to add.

Table 49: Valid combinations of Signal Addition via Hardware
Compilation format Add Signal format Remarks
IQ IQ Valid combination.
IF/RF IF/RF Valid combination.
IF/RF IQ Not a valid combination.
IQ IF/RF Not a valid combination.
xxx

Offset for Carriers
Follow these steps to add frequency offsets to a signal:

1. Select the Interference Addition tab.

2. Select a carrier from the table.

3. Select Turn On to include frequency offsets for the carrier. (Select Turn On again if you want to exclude
frequency offsets. By default, Turn On is set to off.)

4. Set the following parameter:
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Table 50: Offset parameters for carriers
Selection Description Range, Default value
Frequency (Hz) Enter the frequency offset to add. AWG7000 options 02/06: –2.9 GHz

to +2.9 GHz, 0
AWG7000 standard option: –1.75 GHz
to +1.75 GHz, 0
AWG5000: –185 MHz to +185 MHz, 0

xxx

Sinusoidal for Carriers
Follow these steps to add sinusoidal interference to a signal:

1. Select the Interference Addition tab.

2. Select a carrier from the table.

3. Select Turn On to include sinusoidal interference for the carrier. (Select Turn On again if you want to
exclude sinusoidal interference. By default, Turn On is set to off.)

4. Set the following parameters:

Table 51: Sinusoidal parameters for carriers
Selection Description Range, Default value
C/I (dB) Enter the carrier-to-interference ratio. –40 dB to 40 dB, 20 dB
Offset from Carrier (Hz) Enter the offset from the carrier

frequency.
AWG7000 options 02/06: –2.9 GHz
to +2.9 GHz, 0
AWG7000 standard option: –1.75 GHz
to +1.75 GHz, 0
AWG5000: –185 MHz to +185 MHz, 0

xxx

Creating a UWB-WiMedia Signal

Conformance Mode
For a selected signal type (IF/RF or IQ), you can generate a signal in either of these modes:

Conformance Mode

Custom Mode

In the conformance mode, all packet group settings conform to those defined in the standard. However,
you can change some of the parameters for a packet group conforming to the standard.
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1. In the Select Setup field, select one of the following standard setups or select My Setup to create
your own setup:

WiMedia Spec Example Packet

53.3, 80, and 106 Mbps Packets

480 Mbps Burst Mode Packets

When you change the setup selection from one standard to another selection, any changes that you
may have made are lost unless you save the setup. The following message is displayed: All altered
settings will be lost. Do you wish to continue?

However, when you change the setup selection from My Setup to another, changes to My Setup are
saved.

2. In the Add Number of Packet Groups field, type the number of packet groups to add. The maximum
number of packets is 100. Click Add to Table to add the packet group to the table. The newly added
packet group can be renamed by clicking the field and typing new text. Use the Up and Down arrow
buttons to move the packet group up or down.

Select a packet group from the table and click Delete to delete it. The subsequent packet groups
in the table are renumbered.

3. Click Marker Mapping... to set the marker (M1 and M2) levels to On (1) or Off (0) for each packet
group. Keeping M1 and M2 on indicate when symbols in each frequency hopping band are being
output. If the signal format is RF/IF, M1 and M2 of the channel where the RF/IF signal is output will be
used. If the signal format is IQ, M1 and M2 of the channel where the I signal is output will be used.

Custom Mode
For a selected signal type (IF/RF or IQ), you can generate a signal in either of these modes:

Conformance Mode

Custom Mode

In the custom mode, you can define packet parameters for a packet group. Most packet group settings will
be carried from the packet group parameters defined in the conformance mode.

1. In the Select Setup field, select one of the following standard setups or select My Setup to create
your own setup:

WiMedia Spec Example Packet

53.3, 80, and 106 Mbps Packets

480 Mbps Burst Mode Packets

When you change the setup selection from one standard to another selection, any changes that you
may have made are lost unless you save the setup. The following message is displayed: All the altered
settings will be lost. Do you wish to continue?
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However, when you change the setup selection from My Setup to another, changes to My Setup are
saved.

2. In the Add Number of Packet Groups field, type the number of packet groups to add. The maximum
number of packets is 100. Click Add to Table to add the packet group to the table. The newly added
packet group can be renamed by clicking the field and typing new text. The newly added packet
group will have one packet (or PPDU).

Select a packet group from the table and click Delete to delete it. The subsequent packet groups in the
table are renumbered. Use the Up and Down arrow buttons to move the packet group up or down.

For a selected packet group, the packets or PPDUs are displayed in a table.

3. In the Add Number of Packets field, type the number of packets to add. The maximum number of
packets in a packet group is 30. Click Add to Table to add the packets to the table. Use the Up and
Down arrow buttons to move the PPDUs up or down.

For a selected packet, the PPDU details are displayed graphically. You can set or edit these values,
process a selected packet, or set process preferences.

4. Click Marker Mapping... to set the marker (M1 and M2) levels to On (1) or Off (0) for each packet
group. Keeping M1 and M2 on indicate when symbols in each frequency hopping band are being
output. If the signal format is RF/IF, M1 and M2 of the channel where the RF/IF signal is output will be
used. If the signal format is IQ, M1 and M2 of the channel where the I signal is output will be used.

5. Click Restore All to Compliance to restore all the settings as set in the conformance mode.

6. Click Process Preferences to set the processing preferences for the selected packet.

NOTE. When you switch to the Custom mode, settings from the Conformance mode are carried over. If you switch
back to Conformance mode, the settings will be the same as when you left the Conformance mode. All the custom
mode settings will be lost.

Conformance Mode Setup

Packet Group Details for Conformance Mode
The packet group details in the conformance mode are as follows:

Table 52: Packet Group Details for Conformance mode
Selection Description Range, Default value
Repeat this group (times) Enter the number of times the group

is repeated.
1 to 100, 1

Group start delay (symbols) Enter the delay in symbols at the start
of a group.

0 to 200, 32 symbols
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Table 52: Packet Group Details for Conformance mode (cont.)

Selection Description Range, Default value
Group end delay (symbols) Enter the delay in symbols at the end

of a group.
0 to 200, 0 symbols

Number of packets in group Enter the number of packets in a
group. The maximum number would
be limited by the memory size of AWG
that is the number of samples. This
will depend on the oversampling,
signal format (RF or IQ) and the center
frequency.

1 to 30, 1
The maximum number would be
limited by the memory size of AWG
(the number of samples). The
number of samples will depend on the
oversampling, signal format (RF or IQ)
and the center frequency.

Spacing between packets Enter the distance between the
packets to the specified value in
symbols, pMIFS, or pSIFS. The value
defines the time between packets.

Standard Mode: 6 to 200, 6 symbols
Burst Mode: 6 symbols
If Payload length is zero, the Packet
separation is fixed to 32 symbols (1
pSIFS).

Payload data source Enter the source for the packet group
from the following selections: WiMedia
Spec Example, All 0 (Zeros), All 1
(Ones), PRBS 7, PRBS 9, PRBS 15,
PRBS 16, PRBS 20, PRBS 21, PRBS
23, and User Defined.

WiMedia Spec Example

File Select the payload data file (.txt or
.dat) to be used by entering the path
or browsing to the file. Enabled when
payload data source is set to User
Defined.

N/A

xxx

Click Tone Nulling to set the amplitudes for the bands in each packet group.

The following conditions must be met for a valid file:

Any ASCII file, delimited or not, can used as the data source.

The next bit will be generated by reading the file until a 0, 1, x, or X character is found. 0 and 1 will
add the corresponding bit to the sequence; the x and X character will add a new random bit.

Any other intermediate character will be ignored.

When the end of the file is reached, the file is read again from the beginning, based on the Record
Length.

The data can be organized in columns or rows.

Any number of space, tab, or comma characters can be used as a delimiter.

Empty lines or invalid lines at the beginning and end of the file are ignored.

NOTE. When a packet group is repeated many times, the end delay of one packet group and the start delay of
the next packet group are added.
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NOTE. If Payload length is zero, the Packet separation is fixed to 32 symbols (1 pSIFS).

Packet Details for Conformance Mode
The packet details in the conformance mode are as follows:

Table 53: Packet Details for Conformance mode
Selection Description Default value
MAC header Select the MAC header type from the

following: WiMedia Spec Example, All
Zeros, All Ones, PRBS 7, PRBS 9,
PRBS 15, PRBS 16, PRBS 20, PRBS
21, PRBS 23, and User Defined Data
(in Hex).

The maximum length of the MAC
header is 10 bytes. If you enter values
less than 10 bytes, the rest will be
padded with zeros.

Data (HEX) Enter the MAC Header data in
hexadecimal. Enabled when MAC
Header is set to User-Defined Data
(in Hex).

Maximum length is 10 bytes.

Packet mode Select the transmission mode for the
packet from the following: Standard,
Burst.

The default value depends on the
selected setup.

Data rate (Mbps) Select the data rate for the packet
from the following: 53.3, 80, 106.7,
160, 200, 320, 400, and 480 Mbps.

The default value depends on the
selected setup.
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Table 53: Packet Details for Conformance mode (cont.)

Selection Description Default value
Preamble type Select the preamble type from

the following: Standard, Burst. A
Standard preamble has 24 symbols
and a Burst preamble has 12 symbols.

When the Packet mode is set to
Standard, the preamble type is always
Standard.
When the Packet mode is set to Burst
and the data rate ≤200 Mbps, the
preamble type is always Standard.
When the Packet mode is set to
Burst and the data rate > 200 Mbps,
preamble type can be Standard or
Burst.

Packet size (bytes) Enter the size of the packet in bytes. Standard Mode: 0 to 4095
Burst Mode: 1 to 4095
The default values depend on the
selected setup.

xxx

NOTE. If Payload length is zero, the Packet separation is fixed to 32 symbols (1 pSIFS).

Hopping Details for Conformance Mode
The hopping details in the conformance mode are as follows:
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Table 54: Hopping Details for Conformance mode
Selection Description Range, Default value
Band group Select a band group from the

following: BandGroup 1, BandGroup
2, BandGroup 3, BandGroup 4,
BandGroup 5, and BandGroup 6. Sets
the band group to use for transmission
for the select packet or PPDU.

1 to 6. The default values depend on
the quick setup selected. For a newly
added packet group, the default value
is 1.

TF code Select the TF code from the following:
TFC 1, TFC 2, TFC 3, TFC 4, TFC
5, TFC 6, TFC 7, TFC 8, TFC 9, and
TFC 10. Sets the time frequency code
to use to define the hopping sequence
of the packet group.

1 to 10. The default values depend on
the quick setup selected. For a newly
added packet group, the default value
is 1.

Band group center frequency (MHz) Displays the center frequency for
the selected band group. You can
change the center frequency to your
requirement.

The center frequency is restricted
by the sampling rate set for the
instrument and oversampling.

xxx

For a selected combination of Band Group and TF Code, the software displays the channel number. For
example, for Band Group 4 and TFC 8, the channel number is 96. The hopping pattern is dynamically
shown in the Time Vs Centre frequency table. The hopping pattern is as shown:

Custom Mode Setup

Packet Group Details for Custom Mode
The packet group settings in the custom mode are as follows:
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Table 55: Packet Group Details for Custom Mode
Selection Description Range, Default value
Repeat this group (times) Enter the number of times the group

is repeated.
1 to 100

Group start delay (symbols) Enter the delay in symbols at the start
of a group.

0 to 200 symbols, 32

Group end delay (symbols) Enter the delay in symbols at the end
of a group.

0 to 200 symbols, 0

Number of packets in group Enter the number of packets in a
group.

1 to 100
The maximum number is limited by
the memory size of AWG (the number
of samples). The number of samples
depends on the oversampling, signal
format (RF or IQ) and the center
frequency.

Spacing between packets (symbols) Enter the distance between the
packets to the specified value in
symbols, pMIFS, or pSIFS. Indicates
the time between packets.

Standard Mode: 6 to 200, 6 symbols.
Burst Mode: 6 symbols.

Band group Select a band group from the
following: BandGroup 1, BandGroup
2, BandGroup 3, BandGroup 4,
BandGroup 5, and BandGroup 6. Sets
the band group to use to transmit the
selected packet or PPDU.

N/A

TF code Select the TF code from the following:
User defined, TFC 1, TFC 2, TFC
3, TFC 4, TFC 5, TFC 6, TFC 7,
TFC 8, TFC 9, and TFC 10. Sets
the time frequency code to use to
define the hopping sequence of the
packet group. For Band Group 5, the
selections are TFC 5, TFC 6, TFC 8,
and User Defined.

When User defined TFC is selected,
you can set your own hopping pattern
along with TFC number ranging
between 0 to 15. For standard
TFCs, TFC 1 to TFC 10, the hopping
sequence cannot be changed.

No hopping Select this option to generate signals
for the selected TF code without
hopping. However, markers still
continue to hop based on the TFC
pattern.

Disabled

Band group center frequency (MHz) Displays the center frequency for
the selected band group. You can
change the center frequency to your
requirement. The changed frequency
is updated in the Hopping Pattern
dialog box.

N/A

xxx
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NOTE. When a packet group is repeated many times, the end delay of one packet group and the start delay of
the next packet group are added.

NOTE. If you change the TF Code, the change is not reflected in the Packet Sync Sequence (Base Time Domain
Sequence and the Cover Sequence).

When the TF Code is set to User Defined, the Hopping Pattern dialog box is displayed. You can define the
hopping pattern by clicking on the frequency bands. Assign a TFC number for the pattern and click OK
to save the hopping pattern.

Setting PPDU Details
The packet parameters for a selected packet are displayed graphically.

For a packet, you can set the PLCP Preamble, PLCP Header and PSDU parameters. Many parameters
have either a dropdown list to select values from, or a text box to enter values (in hexadecimal or binary).
Other parameters open the next level of choices or a dialog box.

Click Process Preferences to set your preferences for the selected parameters. When you select a particular
parameter in the process preferences, your input for that parameter is used (instead of the computed values).

When you clear a particular parameter in the process preferences, your input for that parameter is ignored.
The software will use the computed values.

You can include the PLCP Header and PSDU while processing the packet. By default they are enabled. To
exclude the PLCP Header, disable it. The resulting packet after processing will not include PLCP Header
information. Similarly, to exclude the PSDU, disable it. The resulting packet after processing will not
include PSDU Header information. Both you disable both, then resulting packet will not include PLCP
Header and PSDU Header information.

When you click Process This Packet, the PPDU frame is formed according to your preferences. After
processing, the packet value is displayed at the lower end of the box.
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PLCP Preamble
You can view the PLCP Preamble parameters by clicking the + sign in the PLCP box. The following
options can be set the PLCP Preamble parameters:

Table 56: PLCP Preamble options for Custom Mode
Selection Displays
Packet Sync Sequence Opens a dialog box with two tabs: Base Time Domain

Sequence and Cover Sequence.
Channel Estimation Sequence Displays the default channel estimation sequence value.

Enter a value between 1 and 6.
xxx
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PLCP Header
You can choose whether to include the PLCP Header in the packet. Select the check box to include the
PLCP Header in the packet. Clear the check box to exclude the PLCP Header in the packet.

The following options are available to set the PLCP Header parameters:

Table 57: PLCP Header options for Custom Mode
Selection Displays Default value
PHY Header Displays a set of parameters. N/A
Tail Bits Displays the current value of the tail

bits. Use the text box to set another
value.

000000 bits

MAC Header Opens a dialog box where you can set
there MAC Header from the following:
WiMedia Spec Example, All Zeros, All
Ones, PRBS 7, PRBS 9, PRBS 15,
PRBS 16, PRBS 20, PRBS 21, PRBS
23, and User-Defined Data (in Hex).

The maximum length of the MAC
header is 10 bytes. If you enter values
less than 10 bytes, the rest will be
padded with zeros.

HCS Displays the current HCS value.
HCS is either a calculated value or is
determined by the inputs. Use the text
box to set another value.

HCS depends on Non-Scrambled
MAC Header and PHY Header.

Tail Bits Displays the current value of the tail
bits. Use the text box to set another
value.

000000 bits

Reed-Solomon Parity Bits Displays the current value of
the Reed-Solomon Parity bits.
Reed-Solomon Parity is either a
calculated value or is determined by
the inputs. Use the text box to set
another value.

Reed-Solomon Parity bits depends
on Scrambled MAC Header+ HCS +
PHY Header.

Tail Bits Displays the current value of the tail
bits. Use the text box to set another
value.

0000 bits

xxx

You can set the following parameters in Process Preferences to take your input: Tail Bits, HCS Tail Bits,
Reed Solomon Parity Bits, and Tail Bits.
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PSDU
You can choose whether to include the PSDU in the packet. Select the check box to include the PLCP
Header in the packet. Clear the check box to exclude the PSDU in the packet.

The following options are available to set the PSDU. PSDU is enabled only if the Length field in PHY
header is not zero.

Table 58: PSDU options for Custom Mode
Selection Displays
Frame Payload Displays the current value of the frame payload (data

source). Click within the box to open a dialog box where
you can choose the payload data source from the following:
WiMedia Spec Example, All Zeros, All Ones, PRBS 7,
PRBS 9, PRBS 15, PRBS 16, PRBS 20, PRBS 21, PRBS
23, and User Defined.

File Select the payload data file (.txt or .dat) to be used by
entering the path or browsing to the file. Enabled when
payload data source is set to User Defined.

FCS Displays the current value of the FCS. Use the text box to
set another value. FCS is either a calculated value or is
determined by the inputs. FCS is calculated on the Payload
data.

Tail Bits Displays the current value of the tail bits. Use the text box
to set another value.

Pad Bits Displays the current value of the pad bits. Use the text box
to set another value.

xxx

You can set the following parameters in Process Preferences to take your input: FCS, Tail Bits, and
Pad Bits.

The length of payload for each packet is taken from the Length field in the PHY header.

Packet Sync Sequence
The Packet Sync Sequence dialog box has two tabs: Base Time Domain Sequence and Cover Sequence.
The Packet Sync File consists of the Base time domain sequence. It will consist of 128 values, which
will be used as the preamble.
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The parameters that can be set are as follows:

80 RFXpress RFX100 User Manual



Creating a UWB-WiMedia Signal Packet Sync Sequence

Table 59: Packet Sync Sequence parameters for Custom Mode
Selection Displays Default value
Base Time Domain Sequence
TF Code Select the TF Code from the following

selections: User defined, TFC 1 (Normal),
TFC 2 (Normal), TFC 3 (Normal), TFC 4
(Normal), TFC 5 (Normal), TFC 6 (Normal),
TFC 7 (Normal), TFC 8 (Normal), TFC 9
(Normal), TFC 10 (Normal), TFC 1 (Alternate),
TFC 2 (Alternate), TFC 3 (Alternate), TFC
4 (Alternate), TFC 5 (Alternate), TFC 6
(Alternate), and TFC 7 (Alternate).
If you set the TF code to User Defined, browse
and select the file from which to take values.

TFC 1 (Normal)

Cover Sequence
TF Code Select the TF Code from the following

selections: User defined, TFC 1, TFC 2, TFC
3, TFC 4, TFC 5, TFC 6, TFC 7, TFC 8, TFC 9,
and TFC 10.
When you set the TF code to User Defined, you
can set the total synchronization length.

TFC 1

Preamble type Select the preamble type: Standard or Burst.
Depending on the preamble type, the index will
change to 24 or 12.

Standard

Total synchronization sequence length Displays the value of the synchronization
sequence length. For Standard Preamble,
the synchronization length is 24 and for Burst
Preamble the synchronization length is 12. If
you set the TF Code to User Defined, you can
set the synchronization value between 1 and
24.

1 to 24, 1

xxx

The Alternate TFC information is available in Appendix D of the latest release of MultiBand OFDM
Physical Layer Specification.

NOTE. The number of symbols in the time domain synchronization sequence is equal to the length of the cover
sequence.

The Time Domain Sequence table displays the Index and standard SBase values for the selected TF Code.
You can double-click on the SBase value in any row and edit it. When the TF Code is set to User Defined,
you must specify a file from which to take data.

The following conditions must be met for a valid file:

The file name extensions are .txt and .dat. The file consists of the Base Time Domain sequence of 128
values which are used as the preamble.
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Time domain sequence values must be stored in columns. The file with the Base Time Domain
sequence should contain 128 data values. If the file contains more than 128 values, the other values will
be ignored. If it contains less than 128 values, zeros will be added to make up the 128 values.

The data should be in floating point precision. Spaces and tabs are ignored. Any other characters,
including blank lines, are considered invalid. RFXpress stops reading data when it encounters invalid
data.

The Cover Sequence table displays the Index and standard SCover values for the selected TF Code. You
can double-click the SCover value in any row and edit it. The total sequence synchronization length is
displayed. When the values are taken from an ASCII file, if file contains more than 128 values, the
rest are ignored.

Click Reset to Default to restore the SCover and SBase values to their default values.
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PHY Header
The PHY Header parameters that can be set are as follows:

Table 60: PHY Header parameters for Custom Mode
Selection Displays
Rsvd Displays the current value in the text box. Use this box to

set another value.
Rate Displays the data rate of the PHY header. Click Rate to

display a dialog box to set the Modulation to DCM or QPSK,
Convolution Encoder to 1/3, 1/2, 5/8, or 3/4, Interleaver,
Conjugate Symmetry, and Time Spreading.

Length Displays the length of the PHY header in bytes between 0
to 4095. Use this field to set another length.

Rsvd Displays the current value in the text box. Use this box to
set another value.

Scrambler INIT Displays the initial value for scrambling. To change this,
select from Seed 00, Seed 01, Seed 10, and Seed 11.

Rsvd Displays the current value in the text box. Use this box to
set another value.

Burst Mode Displays the Burst Mode for the next packet. In each
packet, the next packet can be configured to: Standard and
Burst. The first packet is always Standard.

Preamble Type Displays the Preamble Type. To change this, select from
Standard and Burst.

TX TFC Displays the TX TFC number.
Band Group Displays the Band Group.
Rsvd Displays the current value in the text box. Use this box to

set another value.
xxx

You can set the Rsvd bits in Process Preferences to take your input.
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MAC Header
This dialog box is displayed when you click MAC Header (Selected PPDU Details) in the Setup tab
(UWB-WiMedia) in the Custom mode. The MAC Header parameters that can be set are as follows:

Table 61: MAC Header parameters for Custom Mode
Selection Displays Default value
MAC Header Displays the default MAC Header. To

change this, select from the following:
WiMedia Spec Example, All Zeros, All
Ones, PRBS 7, PRBS 9, PRBS 15,
PRBS 16, PRBS 20, PRBS 21, PRBS
23, and User-Defined Data (in Hex).

The maximum length of the MAC
header is 10 bytes. If you enter values
less than 10 bytes, the rest will be
padded with zeros.

Field Enter the MAC Header data in
hexadecimal. Enabled when MAC
Header is set to User-Defined Data
(in Hex).

D3C2368C8F360DBBEDBA

xxx
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I/Q Impairments

Carrier Leakage for UWB-WiMedia
Follow these steps to define carrier leakage for a signal:

1. Select the I/Q Impairments tab.

2. Select Turn On to include carrier leakage (I and Q) impairments to a packet group. (Select Turn On
again if you want to exclude carrier leakage (I and Q) impairments. By default, Turn On is disabled.)

3. Set the carrier leakage for I and Q modulator signal in percentage.

Table 62: Carrier leakage parameters for UWB-WiMedia
Selection Description Range, Default value
I (%) Enter the carrier leakage for the I

signal.
–50% to +50%, 0%

Q (%) Enter the carrier leakage for the Q
signal.

–50% to +50%, 0%

xxx

Quadrature Error for UWB-WiMedia
Quadrature Error allows you to control the phase angle between the I and Q signals. Follow these steps
to define quadrature error for a signal:

1. Select the I/Q Impairments tab.

2. Select Turn On to include quadrature error for a packet group. (Select Turn On again if you want to
exclude quadrature error. By default, Turn On is disabled.)

3. Quadrature error is defined in degrees. A positive value indicates that the phase angle is greater than 90
degrees. Set the following parameter:

Table 63: Quadrature error parameters for UWB-WiMedia
Selection Description Range, Default value
Degrees Enter the phase angle between the I

and Q signals.
–30° to +30° , 0°

xxx
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I/Q Imbalance for UWB-WiMedia
I/Q Imbalance allows you to create gain imbalance between I and Q. Follow these steps to define I/Q
imbalance for a signal:

1. Select the I/Q Impairments tab.

2. Select Turn On to include I/Q imbalance for a packet group. (Select Turn On again if you want to
exclude I/Q imbalance. By default, Turn On is disabled.)

3. I/Q imbalance is defined in percentage. Set the following parameter:

Table 64: I/Q imbalance parameters for UWB-WiMedia
Selection Description Range, Default value
Percentage Enter the imbalance between the I

and Q signals.
–30% to +30%, 0%

xxx
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Non-Linear Distortion for UWB-WiMedia
Non-linear Distortions allow you to simulate the non-linearity of IQ modulators. Follow these steps to
define non-linear distortions for a signal:

1. Select the I/Q Impairments tab.

2. Select Turn On to include non-linear distortions for a packet group. (Select Turn On again if you want
to exclude non-linear distortions. By default, Turn On is disabled.)

3. Set the following AM/AM and AM/PM parameters:

The variation of the signal amplitude with respect to the original amplitude is called AM/AM conversion.

Table 65: AM/AM parameters for UWB-WiMedia
Selection Description Range, Default value
k2 dB Enter the second order coefficient for

the magnitude.
–3 dB to +3 dB, 0 dB

k3 dB Enter the third order coefficient for the
magnitude.

–3 dB to +3 dB, 0 dB

xxx

The variation of the phase with respect to the original amplitude is called AM/PM conversion.

Table 66: AM/PM parameters for UWB-WiMedia
Selection Description Range, Default value
k2 degrees Enter the second order coefficient for

the phase.
–30° to +30°, 0°

k3 degrees Enter the third order coefficient for the
phase.

–30° to +30°, 0°

xxx

See also:

Non-Linear Impairments
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Hardware Skew for UWB-WiMedia
The number of channels shown depends upon the AWG being used. Follow these steps to define hardware
skew for a signal:

1. Select the I/Q Impairments tab.

2. Select Turn On to include hardware skew for a packet group. (Select Turn On again if you want to
exclude hardware skew. By default, Turn On is disabled.)

3. Set the following parameters:

Table 67: Hardware skew parameters for UWB-WiMedia
Selection Description Range, Default value
Channel N (ps) Enter a value for each channel.

Adjusting the skew dynamically
updates the dialog box display. The
adjustment applies to analog output
and marker output.

AWG7000: –100 ps to +100 ps, 0 ps
AWG5000: –5 to +5 ns, 0 ns

xxx

Distortion Addition

Amplifier for UWB-WiMedia
Amplifier Distortion simulates the non-linearity in the amplifier. You can set the amplifier distortion
to Non-Linear, Hardlimiting, or Softlimiting. Hardlimiting and softlimiting amplifiers affect only the
amplitude of the output signal. The phase of the output signal is not affected.

Follow these steps to define amplifier distortion for a signal:

1. Select the Distortion Addition tab.

2. Select a carrier from the table.

3. Select Turn On to include amplifier distortion for a packet group. (Select Turn On again if you want
to exclude amplifier distortion. By default, Turn On is disabled.)

4. Set the following parameters:

Table 68: Amplifiers parameters for UWB-WiMedia
Selection Description Range, Default value
Amplifier Select the amplifier distortion from the following: Non-Linear,

Hardlimiting, and Softlimiting.
Non-Linear

Operating point Enter the operating point of the nonlinear amplifier. 0.01 to 1000, 0.01
Limiting Level Enter the limiting level for the Hardlimiting and Softlimiting

amplifiers.
0.1 to 1000, 0.1

xxx

The following AM/AM parameters are available for a non-linear amplifier:
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Table 69: AM/AM parameters for UWB-WiMedia
Selection Description Range, Default value
k3 (dB) Enter the third order coefficient for the magnitude. –3 dB to +3 dB, 0 dB
k5 (dB) Enter the fifth order coefficient for the magnitude. –3 dB to +3 dB, 0 dB
xxx

The following AM/PM parameters are available for a non-linear amplifier:

Table 70: AM/PM parameters for UWB-WiMedia
Selection Description Range, Default value
k3 (degrees) Enter the third order coefficient for the phase. –30° to +30°, 0°
k5 (degrees) Enter the fifth order coefficient for the phase. –30° to +30°, 0°
xxx

See also:

Amplifier Distortions
MultiPath

Multipath Parameters for UWB-WiMedia
Follow these steps to set multipath parameters for a signal:

1. Select the Multi-Path tab.

2. Select Turn On to define the path. (Select Turn On again if you want to exclude multipath parameters.
By default, Turn On is disabled.)

3. Set the following parameters:

Table 71: Multipath parameters for UWB-WiMedia
Selection Description Range, Default value
Delay (symbols) Enter the delay in symbols from the

reference path. The delay can be
positive or negative. The delay values
cannot be repeated.

–2 to +2 symbols, 0 symbols

Amplitude (dB) Enter the amplitude in dB from the
reference path. The amplitude is
always negative.

–60 to 0 dB, 0dB

Phase (deg) Enter the phase in degrees from the
reference path. The phase can be
positive or negative.

–180 to +180 degrees, 0 degree

xxx

4. Click Add to add the parameters to the table. Select a row and click Delete to delete it from the table.

You can define a maximum of ten multipaths, including the reference path that has the delay, amplitude
and phase values set to zero. You can neither delete the reference path with a delay of 0 symbols nor
change the delay value. However, you can change the amplitude and phase values. No two paths can
have the same delay value. The table rows are automatically sorted in the ascending order of the delay
value. The table contains the Delay, Amplitude, and Phase that you entered.
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Depending on the entered delay value, the application might have to recompute the convolution length.
This happens if convolution length provided is not enough for the given multipaths. In this case, the
following message appears: Convolution length will be adjusted to take care of multipaths. Do you
want to adjust? You can choose to adjust or not adjust the convolution length.

Multi-path is created by applying the right algorithm to the baseband I and Q signals. The application
generates a new complex isolated pulse by convolving the direct isolated pulse and the channel impulse
response (it is a complex impulse response at the baseband level). This implies that to have the right
convolution, the total length of the resulting process must be long enough to accommodate the new
isolated pulse.
Interference Addition

Signal Addition for UWB-WiMedia
Follow these steps to define signal interference for a signal:

1. Select the Interference Addition tab.

2. Select Turn On to include signal interference for a packet group. (Select Turn On again if you want
to exclude signal interference. By default, Turn On is disabled.)

3. Set the following parameters:

Table 72: Signal addition parameters for UWB-WiMedia
Selection Description Default value
Format
I/Q Specifies the signal format of the file to be added. I/Q
IF/RF Specifies the signal format of the file to be added. N/A
Add Interference via:
Software Specifies that the interference addition will be through software. Software
Hardware Specifies that the interference addition will be through hardware. N/A
Waveform_I Click the icon next to the Waveform_I field and a list of waveforms

appears. Select the I waveform to use.
N/A

Waveform_Q Click the icon next to the Waveform_Q field and a list of
waveforms appears. Select the Q waveform to use.

N/A

Waveform_RF Click the icon next to the Waveform_RF field and a list of
waveforms appears. Select the RF waveform to use.

N/A

xxx

When the Signal format is IQ, two interference channels are required, which means that an
AWG5000 series with four channels is required. If you do not have a 4-channel AWG, then the warning
message appears: AWG has only X channels, cannot send interference data to channel.

When the Signal format is IF/RF, at least one channel should be available for interference, otherwise a
message appears: AWG7101, AWG7102 interleave mode cannot be used.

4. If you set Add Interference via to Hardware, the interference should go to Ch2 and you need to connect
Ch1 output to Ch2 external signal addition input.

NOTE. The AWG7000 series does not support external signal addition via hardware.
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Signal Addition via Software
The following table shows the combinations of the signal you want to generate after compilation and the
interference signal that you want to add.

Table 73: Valid combinations of signal addition via software for UWB-WiMedia
Compilation format Add Signal format Remarks
IQ IQ Valid combination.
IF/RF IF/RF Valid combination.
IF/RF IQ Valid combination. I/Q interference

signals will be added before
modulation.

IQ IF/RF Not a valid combination.
xxx

Signal Addition via Hardware
The following table shows the combinations of the signal you want to generate after compilation and the
interference signal that you want to add.

Table 74: Valid combinations of signal addition via hardware for UWB-WiMedia
Compilation format Add Signal format Remarks
IQ IQ Valid combination.
IF/RF IF/RF Valid combination.
IF/RF IQ Not a valid combination.
IQ IF/RF Not a valid combination.
xxx

Offset for UWB-WiMedia
Follow these steps to add frequency offsets to a signal:

1. Select the Interference Addition tab.

2. Select Turn On to include frequency offsets for a packet group. (Select Turn On again if you want to
exclude frequency offsets. By default, Turn On is disabled.)

3. Set the following parameter:
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Table 75: Offset parameters for UWB-WiMedia
Selection Description Default value
Frequency (Hz) Enter the frequency offset to add. AWG7000 options 02/06: –2.9 GHz

to +2.9 GHz, 0
AWG7000 standard option: –1.75 GHz
to +1.75 GHz, 0
AWG5000: –185 MHz to +185 MHz, 0

xxx

Gated Noise for UWB-WiMedia
You can apply gated noise to either certain segments of the packets or through a range of symbols. The
packet segments that you can apply noise to are: Preamble, PLCP Header, or the Payload. You can
define a range of symbols to which to apply noise.

A negative signal to noise value indicates that the noise added will be greater than the signal amplitude.
Conversely, a positive signal to noise value indicates that the noise added will be smaller than the signal
amplitude.

Follow these steps to add gated noise to a signal:

1. Select the Interference Addition tab.

2. Select Turn On to include gated noise for a packet group. Select Turn On again to exclude gated
noise. By default, Turn On is disabled.

3. Set the following parameters:

Table 76: Gated noise parameters for UWB-WiMedia
Selection Description Range, Default value
Packets Select Packets to define the packet

parameters.
Enabled

Preamble (S/N) (dB) Enable the option and enter the signal
to noise ratio for the preamble.

–40 to +20 dB, 0

PLCP Header (S/N) (dB) Enable the option and enter the signal
to noise ratio for the PLCP header.

–40 to +20 dB, 0

Payload (S/N) (dB) Enable the option and enter the signal
to noise ratio for the payload.

–40 to +20 dB, 0

Symbols Select Symbols to define the symbol
parameters.

Disabled

Packet range Enter the range of packets from the
start packet through the end packet.

From: 0 to 59039, 0
To: 0 to 59039, 0

S/N (dB) Enter the signal to noise ratio. –40 to +20 dB, 0
xxx
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The following figure shows an example of a signal with gated noise.

The following figure shows an example of a signal without gated noise.
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The following figure shows an example of a gated noise applied to a range of symbols.

Sinusoidal for UWB-WiMedia
Follow these steps to add sinusoidal interference to a signal:

1. Select the Interference Addition tab.

2. Select Turn On to include sinusoidal interference for a packet group. (Select Turn On again if you want
to exclude sinusoidal interference. By default, Turn On is set to off.)

3. Set the following parameters:

Table 77: Sinusoidal parameters for UWB-WiMedia
Selection Description Default value
C/I (dB) Enter the carrier-to-interference ratio. –60 dB to 60 dB
Offset from Carrier (Hz) Enter the offset frequency of the interferer

sample.
AWG7000 options 02/06: –2.9 GHz to
+2.9 GHz, 0
AWG7000 standard option: –1.75 GHz to
+1.75 GHz, 0
AWG5000: –185 MHz to +185 MHz, 0

xxx
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Real-World Signal Interference
Follow these steps to add real-world interference to a signal:

1. Select the Interference Addition tab.

2. Select Turn On to include real-world interference for a packet group. (Select Turn On again if you want
to exclude real-world interference. By default, Turn On is set to off.)

3. Set the following parameters:

Table 78: Real world signal parameters for UWB-WiMedia
Selection Description Range, Default value
Add WiMax signal Enable this option to add WiMax interference to the UWB signal. Disabled
Frequency (Hz) Enter the frequency of the WiMax signal to add. Depends on the

instrument bandwidth,
2.5 GHz

Amplitude (dB) Enter the amplitude of the WiMax signal to add. –60 dB to + 60 dB, 0 dB
Add WiFi signal (MIMO) Enable this option to add WiFi (MIMO) interference to the UWB

signal.
Disabled

Frequency (Hz) Enter the frequency of the WiFi (MIMO) signal to add. Depends on the
instrument bandwidth,
2.4 GHz

Amplitude (dB) Enter the amplitude of the WiFi (MIMO) signal to add. –60 dB to + 60 dB, 0 dB
Add WiFi signal
(802.11a)

Disabled

Frequency (Hz) Enter the frequency of the WiFi (802.11a) signal to add. Depends on the
instrument bandwidth,
2.4 GHz

Amplitude (dB) Enter the frequency of the WiFi (802.11a) signal to add. –60 dB to + 60 dB, 0 dB
Add radar signal Enable this option to add radar interference to the UWB signal. Disabled
Frequency (Hz) Enter the frequency of the radar signal to add. Depends on the

instrument bandwidth,
1 GHz

Amplitude (dB) Enter the amplitude of the radar signal to add. –60 dB to + 60 dB, 0 dB
xxx

The radar signal that the application adds has the following properties:

Modulation: LFM (Linear Frequency Modulated) Pulse.

Pulse width: 5 usec

Frequency sweep: 20 MHz

PRI: 800 usec
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Calibration for UWB-WiMedia Signals

Using Calibration for IF/RF Signals
Calibration is available only when the software is running on an AWG5000 or AWG7000 series.

For IF/RF signals connect the arbitrary waveform generator and oscilloscope as follows:

Creating Correction Files
1. Select Calibration from the toolbar.

2. Select the Signal Type.

3. From the list of instruments, highlight an oscilloscope and click Connect.

4. Set the Calibration parameters. The calibration parameters are: Sampling Frequency, Interleave,
Zeroing, Calibration Reminder, Average, Generator Center Frequency, Band Group Center Frequency,
and Sideband. You can leave these parameters with their default values or set them as you like.

However, you must set the following parameters: Band Group, Bands, and Channels to which
correction files apply.

NOTE. Interleave and Zeroing are available on the AWG7000 series with Option 06.

The following table lists the Band Groups and their center frequencies for IF and RF signals.

Table 79: Band groups and center frequencies for If and RF signals
Band Group RF Center Frequency IF Center Frequency
1 3960 MHz 1000 MHz
2 5544 MHz 1000 MHz
3 N/A 1000 MHz
4 N/A 1000 MHz
5 N/A 1000 MHz
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Table 79: Band groups and center frequencies for If and RF signals (cont.)

Band Group RF Center Frequency IF Center Frequency
6 N/A 1000 MHz
User Defined Band Group Center Frequency is enabled

when user-defined band group is selected. You
can enter any frequency value within the range
of 500 KHz to 10 GHz.

Band Group Center Frequency is enabled
when user-defined band group is selected. You
can enter any frequency value within the range
of 1 GHz to 20 GHz.

xxx

NOTE. BandGroup3 to BandGroup6 are not available in RF due to the limitation of the AWG7000 bandwidth.

5. For each channel, set the path and file name of the correction file. The correction files will be created in
the specified location.

6. Click Calibrate. A status message displays the status of processing. The AWG creates a signal averaged
(the number of iterations) as specified by Average field and sends it to the oscilloscope.

The reference signal is generated using the oscilloscope parameters.

NOTE. The difference between the generated signal and the reference signal is calculated for each iteration.

7. The corrections files (.rfc) created contain both Magnitude and Phase information specific for the
selected channel, band group and bands.

Applying Correction Files During Compilation
To apply the correction files creation by calibration, follow these steps:

1. Click Compile > Compile Settings from the toolbar.

2. In the Compile Settings dialog box, select the When compiling apply correction files to these channels
option and select the channels depending on the AWG model.

3. Click Compile. The correction files are applied while compiling the signal. The signal is displayed
in the Waveform List.

Instrument Control

Controlling an Instrument
RFXpress can be used to control a connected instrument (for example a Tektronix oscilloscope or an
Agilent Performance Signal Generator E8267D with Option 015) in many ways: You can:

Install RFXpress on an AWG5000/AWG7000 series instrument. RFXpress can directly send and
receive data from the AWG.

Install an offline version of RFXpress on a PC with an offline version of the AWG software. In this
case, RFXpress can detect the presence of the AWG and send data to it. This data can be opened and
viewed in the AWG.
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Install RFXpress on a PC and use it to control an Agilent E8267D and any Tektronix oscilloscope. The
software uses TekVisa ver.3.0.2.33 to interface with the Agilent E8267D and the oscilloscope. The
instruments can be connected using LAN or GPIB.

Follow these steps to find other instruments connected to the instrument on which RFXpress is running:

1. Click Find Instruments. The following dialog box opens.

The table lists the instruments found along with the name of the instrument, model, status (connected or
not), and the connection type (Ethernet or GPIB).

2. Select an instrument from the table. Use the following buttons to:

Table 80: Find instruments options and their description
Button Description
Connect Allows you to Connect to the instrument selected in the table. Enabled is default if an instrument is

highlighted in the table; disabled if no instrument is highlighted.
Disconnect Allows you to Disconnect the connected instrument. Enabled only when an instrument is connected.
Refresh Refreshes the list of instruments.
Import... Opens the Import from Tektronix Oscilloscope dialog box.
xxx

3. Click Connect to connect to the selected instrument.

Controlling an Arbitrary Waveform Generator (AWG)
Waveform transfer and control of the AWG5000 and AWG7000 series can be performed directly from
RFXpress. You can run the software on an AWG5000 or AWG7000 series arbitrary waveform generator
and control it.

1. Select Window > Instrument Control.
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2. From the AWG tab, you can modify the values of the following AWG parameters:

Table 81: AWG parameters
Selection Description Default value
Sampling Rate Displays the sampling rate of the arbitrary

waveform generator.
The default is as set in the AWG.

Interleave Sets the interleave option to On or Off. Off
Zeroing Enabled only when Interleave is set to On. Cleared or unchecked.
Channel (On/Off) Select the channel or channels to receive the

output from these channels.
This depends on the number of channels
present on the AWG.

Amplitude (Vpp) Displays the amplitude of the selected
channel. Change the amplitude in this field
to change the amplitude on the channel.

The default is as set in the AWG.

Offset (V) Displays the amplitude offset of the selected
channel. Change the amplitude in this field to
change the amplitude offset on the channel.

The default is as set in the AWG.

Waveform button Opens the Waveform List and allows you to
select the waveform to be output.

Cleared or unchecked.

Waveform Displays the selected waveform name. You
can drag and drop the waveform from the
Waveform List. When you drag and drop a
waveform, the sampling rate is automatically
set.

N/A

xxx

The following button is available:

Table 82: AWG options
Button Description
Advanced Opens a dialog box where you can set the advanced options.
xxx

3. When you click Advanced, the following options are available for each channel:
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Table 83: Advanced AWG parameters
Selection Description
DAC Resolution
8 bits Sets the DAC resolution to 8 bits.
10 bits Sets the DAC resolution to 10 bits. When the DAC resolution is set to 10 bits, the marker options

are not available.
Markers (M1 and M2)
High (V) Enter the high value for the markers.
Low (V) Enter the low value for the markers.
Delay (s) Enter the maker delay.
xxx

NOTE. When connected to the AWG5000 series instruments, DAC resolution is fixed to 14 bits and cannot be
changed.

Connecting to and Controlling an Oscilloscope
You can connect to and control a Tektronix oscilloscope using RFXpress.

1. Select Window > Instrument Control.

2. A table lists the connected oscilloscopes. From the Oscilloscope tab, you can modify the values of
the following oscilloscope parameters:
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NOTE. Ensure that the Sampling mode on the oscilloscope is set to Real Time. If the Sampling mode is set to
Interpolation (either automatically or manually), the parameter values in RFXpress Instrument control and the
oscilloscope may not match.

Table 84: Oscilloscope parameters
Selection Description
Vertical settings
Channel Displays the channel to which to output the signal. To change this setting, select another

channel.
Scale (V) Displays the vertical scale set in the oscilloscope for the selected channel. Change the value in

this field to change the vertical scale on the connected instrument.
Horizontal settings
Scale (s) Displays the horizontal scale set in the oscilloscope. Change the value in this field to change

the horizontal scale on the connected instrument.
Record length Displays the record length set in the oscilloscope. Change the value in this field to change the

record length on the connected instrument.
Sampling rate
(Samples/sec)

Displays the sampling rate set in the oscilloscope. Change the value in this field to change the
sampling rate on the connected instrument.

Acquisition
Run Starts the acquisition of data in on the oscilloscope.
Stop Stops the acquisition of data on the oscilloscope.
Single Sets the oscilloscope to acquire one full record length and then stop.
xxx

The following buttons are available in this tab:

Table 85: Oscilloscope options
Button Description
Autoset Performs Autoset on the oscilloscope.
Refresh Settings Refreshes the display with the current instrument settings.
Refresh List Refreshes the connection status of the instruments.
Find Instruments Finds instruments on the network.
xxx

Connecting to and Controlling a Performance Signal Generator (PSG)
You can connect to and control an Agilent performance signal generator (E8267D with Option 015)
using RFXpress.

1. Select Window > Instrument Control.

2. In the PSG tab, the following parameters as set on PSG are displayed. However, you can modify the
values of the PSG parameters:
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Table 86: PSG parameters
Selection Description
Signal
Frequency (GHz) Displays the frequency of the signal. Change the frequency in this field to change the

frequency on the connected instrument.
Frequency offset (Hz) Displays the frequency offset of the signal. Change the frequency offset in this field

to change the frequency offset on the connected instrument.
Amplitude (dBm) Displays the amplitude of the signal. Change the amplitude in this field to change the

amplitude on the connected instrument.
Amplitude offset (dB) Displays the amplitude offset of the signal. Change the amplitude offset in this field

to change the amplitude offset on the connected instrument.
Output
RF Select On to set the output format of the signal to RF.
Mod Select On to set the output format of the signal to MOD.
xxx

The following buttons are available:

Table 87: PSG options
Button Description
Advanced Opens a dialog box where you can set the advanced options.
Refresh Refreshes the display with the current instrument settings.
Test Connection... Checks the state of the connection and displays the status.
Find Instruments Finds instruments on the network.
xxx

3. When you click Advanced, the following options are available:
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Table 88: Advanced PSG parameters
Selection Description
Signal
Source Type Displays the source type of the signal. To change this select one of the following:

EXT, INT, BBG1, EXT600, and OFF.
Frequency Mode Displays the frequency mode of the signal. To change this, select on of the following:

FIX, CW, SWE, and LIST.
ALC
ALC: On, Off Sets ALC to On or Off.
ALC Mode Displays the ALC mode of the signal. To change this, select on of the following:

FIX, SWE, and LIST.
ALC Bandwidth (Hz) Displays the ALC bandwidth.
ALC Level (dBm) (Volts) Displays the ALC level.
ALC Power Displays the ALC power of the signal. To change this, select on of the following:

ON, OFF, and ONCE.
Attenuation (dB) Displays the attenuation.
Carrier Leakage Suppression
IQ State When set to On, suppresses the IQ State.
IQ Adjustment When set to On, suppresses the IQ Adjustment.
I Offset (volts) Offsets the I signal.
Q Offset (volts) Offsets the Q signal.
xxx
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Graphing Zooming Graphs

You must click Refresh to update any new settings on the performance signal generator.
Graphing

Zooming Graphs
You can zoom in or zoom out on a graph. You can zoom in on a plot by selecting an area of interest.
RFXpress supports four levels of zoom.

The following graphs provide zoom buttons that help you zoom the plot:

Spectrum

I(t), Q(t)

See also:

Graph

Pulse Shape
The pulse shape graph shows the plot of Points (X-axis) and Amplitude (Y-axis).
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I(t), Q(t)
The I (t), Q(t) graph shows two plots: Points (X-axis) against Inphase(t) (Y-axis), and Points (X-axis)
against Quadrature(t) (Y-axis).

The cursor readouts show the X and Y values and delta of the cursor positions. Moving the cursors causes
the cursor readouts and the delta values to be updated. You can also specify the points values in the
fields to position the cursors.

The following controls are available:

Zoom In: Click Zoom In. Select an area on the plot to zoom in on. You can use the horizontal scroll bar
to scroll through the plot while in the zoom mode.

Zoom Out: Click Zoom Out to zoom out in the same manner that you zoomed in.
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CCDF Plot
The CCDF graph shows the plot of dB over Average Power (X-axis) and % of Time (Y-axis). The readouts
show the % of Time, the dB over Average Power, and the Crest Factor. You can specify the dB over
Average Power value in the field to position the cursor.
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Spectrum
The Spectrum graph shows a plot of Frequency (MHz) on the X-axis and Amplitude (dB) on the Y-axis.
The Cursor 1 and Cursor 2 positions, and the Delta (between the cursor positions) are displayed. Moving
the cursors causes the cursor readouts and the delta values to be updated. You can also specify the
frequency values in the fields to position the cursors. The number of FFT points (8192) and average
points are also shown.

The following controls are available:

Zoom In: Click Zoom In. Select an area on the plot to zoom in on. You can use the horizontal scroll bar
to scroll through the plot while in the zoom mode.

Zoom Out: Click Zoom Out to zoom out in the same manner that you zoomed in.

Averaging
If the number of sample points is high, you can use the Average field to enter a value and average the FFT
data. The value entered in the average field can range from 1 to 1024.
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Constellation Plotting
The constellation graph shows the plots of Points (X-axis) against I and Q (Y-axis). It is a graphical
representation of permissible modulation states at the I/Q level.
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Reference Eye Diagram

Eye Diagram
The Eye Diagram shows the plots of Points (X-axis) against I and Q (Y-axis).

Reference
Error Messages

Error Messages for Generic Signal
Error message Description Possible solution
Waveform Errors
Error generating waveform. An exception occurred while running

the application.
Restart the application.

Waveform does not exist. Operation in an illegal state. Delete all the waveforms.
Memory failed. Operation in an illegal state.

Memory overflow.

Try one of the following:

Restart the application.

Free space on the hard disk.
Data not found. Accessing data beyond range. Delete all the waveforms.
Invalid size. The waveform length is beyond the

range.
Check the range help page for valid
range.

Maximum number of waveforms: 100. The limit of 100 is reached on
completing the selected operation.

Delete waveforms which are not in
use.
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Error message Description Possible solution
Invalid sampling rate. The clock rate from the file is incorrect. Check the format of the file being

imported.
Unable to access data. The application is the invalid state. Restart the application.
Generic Signal Errors
Symbol Map table cannot be empty. The table should have valid entries. Check the parameters in the

Modulation Symbol map table.
Maximum number of carriers: 512. The maximum carriers that can

be generated by the application is
reached.

Delete the carriers that are not in use.

No carrier available. At least one carrier is required to
produce data.

Try one of the following:

Add at least one carrier to the
table.

At least one carrier should have
the State turned ’ON’

User defined file name cannot be
empty.

Valid files need to be present. Valid files need to be present.

File does not exist. The file does cannot be found. The
file may be deleted.

Select existing files.

The interference input signal
waveforms cannot be the same as the
compile waveforms.

The waveform will be overwritten. Try one of the following:

Select a different name for the
compilation waveform.

Rename the waveform in the list
and select the waveform again.

Base data file not found. The file was deleted after updating the
setup.

Select existing base data files.

Filter file not found. The user-defined filter file was not
selected.

Select a user-defined filter file.

Modulation Symbol file not found. The user-defined symbol file was not
found.

Select a user-defined symbol file.

Modulation Sample file not found. The user-defined sample file was not
found.

Select a user-defined sample file.

Maximum total symbols: 512. The total number of symbols of 512 is
exceeded.

N/A

Error on parsing PRBS polynomial. The PRBS polynomial syntax is
incorrect.

Enter the correct PRBS polynomial.

Symbol rate should be less than
carrier frequency.

The specified symbol rate is greater
than the carrier frequency.

Enter a symbol rate that is less than
the carrier frequency.
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xxx

Error Messages for UWB-WiMedia
Error message Description Possible solution
Length of arrays does not match the
size in RFC file.

The correction file may be corrupt. Calibrate again.

Select at least one band for calibration. The band data is required for
calibration.

Select at least one band.

Enter valid correction file path in Ch
N tab.

The path does not exist. Select an existing file path.

Select at least one channel to apply
corrections.

Choose the channel to which the
calibration should be applied.

N/A

Select both the channels to apply
corrections.

IQ Signal format requires two channels
for signal generation.

Select appropriate I and Q channels.

Initialization for the test signal
generation is failed.

Invalid parameters were used. Rerun the calibration after closing and
opening the window.

Error in generating Test Signal. The test signal file was corrupt. Restart the application.
Failed to set calibration signal
parameters.

Invalid parameters were used. Rerun the calibration after closing and
opening the window.

Initialization for the reference signal
generation has failed.

Invalid parameters were used. Rerun the calibration after closing and
opening the window.

Error in generating Reference Signal. The reference signal file was
corrupted.

Restart the application.

Error in setting Reference Signal. Invalid parameters were used. Rerun the calibration after closing and
opening the window.

Failed to set oscilloscope parameters.
Error in acquiring signal from
oscilloscope.
Error in setting oscilloscope signal.
Error in averaging the signal.

The oscilloscope communication was
not successful.

Check the oscilloscope connections.
Try one of the following:

Refresh the list in Find
Instruments window.

Refresh the TekVISA instrument
manager.

Close the application. Restart
TekVISA. Restart the application.

Restart the oscilloscope.
Correction file does not exist. Please
calibrate to generate correction files.

Correction files need to be given if
correction is chosen.

Try one of the following:

Select existing correction files to
apply for correction.

Choose not to give correction
files.

Invalid correction file. Correction file format is incorrect. Apply valid correction files.
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Error message Description Possible solution
Correction file not found. The correction file was deleted after

updating the values in window.
Select existing correction files.

Compilation aborted. One or more
user defined file(s) does not exist.

The user-defined payload data source
file in the conformance mode is
incorrect.

Select the correct payload data source
data file.

Payload file does not exist. Payload data source user defined file
custom mode is incorrect.

Select the correct payload data source
data file.

No packets present in the current
configuration.

At least one packet is necessary for
generating data.

Select at least one valid packet.

Compilation aborted. The correction files do not match with
the selected channel.

Calibrate and choose appropriate
correct correction files.

xxx
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Miscellaneous Error Messages
Error message Description Possible solution
Compile failed. Invalid parameters were found during

compilation.
Check compilation parameters
before compiling.

Restart the application.
Maximum number of averages: 1024. The total number of averages exceeds

1024 in the spectrum plot.
N/A

Invalid file extension. This file type is not supported by the
application for import.

Select the right format supported by
the application.

Invalid file type. Data can not be
imported.

The file contains wrong data.

The data (in the file) does not
match the file type specified during
file import.

Use a valid file.
Specify the type of data in the file
correctly.

Unable to retrieve the file size. The file size could not be computed
based on the data in the file.

Use a valid file.

Unable to create buffer for the
imported file.

The software is unable to allocate the
required memory for importing the file.

Release memory by deleting some
waveforms in the waveform list.

Unable to load the setup file.
Application not available.

The selected setup file cannot be
loaded because the application
(UWB-WiMedia) is not available.

Use a valid file.
Purchase the UWB-WiMedia
application.

Error opening setup file. File cannot
be opened.

The setup file is corrupt and cannot
be opened.

Use a valid file.

Invalid data in the setup file. File may
be corrupted.

The setup file contains invalid data or
may be corrupt.

Use a valid file.

Error loading data from the setup file.
File cannot be loaded.

The data contained in the setup file is
not usable.

Use a valid file.

Error writing the setup file. File cannot
be written.

The setup file is not writable. The
setup file may be read only.

Check whether the file is being
used by another program.

Check the file properties.
Error opening the data file. File cannot
be opened.

The data file is corrupt and cannot be
opened.

Use a valid file.

Error writing the data file. File cannot
be written.

The data file is not writable. The data
file may be read only.

Check whether the file is being
used by another program.

Check the file properties.
Error reading the data file. File cannot
be read.

The data contained in the file is not
usable.

Use a valid file.

No waveform selected in the waveform
list.

No waveform has been selected to
save.

Select a waveform to save.

xxx
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Miscellaneous Error Messages 2
Error message Description Possible solution
Invalid selection of waveforms. Only
one waveform must be selected.

More than one waveform is selected
to save.

Select only one waveform at a time
to save.

Error opening the IQT file. File cannot
be opened.

The .iqt file is corrupt and cannot be
opened.

Use a valid file.

Error reading the IQT file. File cannot
be read.

The .iqt file is corrupt and cannot
be opened.

The data contained in the .iqt file
is not usable.

Use a valid file.

Error opening the TIQ file. File cannot
be opened.

The .tiq file is corrupt and cannot be
opened.

Use a valid file.

Invalid data in the TIQ file. File may
be corrupted.

The .tiq file contains invalid data or
may be corrupt.

Use a valid file.

Error reading the TIQ file. File cannot
be read.

The .tiq file is corrupt and cannot
be opened.

The data contained in the .tiq file
is not usable.

Use a valid file.

Selected waveforms have different
length.

Spectrum calculation requires
waveforms of same length.

Select I and Q format waveforms of
same length from the waveform list.

Unable to retrieve the license
information.

The option key string or the serial
number is incorrect.

Enter the correct option key string or
serial number.

Invalid option string. CRC error in
option string.

Incorrect option key string. Enter the correct option key string.

Invalid option string. Incorrect unique
ID.

Mismatch of the option key string and
the associated serial number.

Enter the correct option key string and
associated serial number.

Invalid option string. Incorrect option key string. Enter the correct option key string.
Compilation aborted. Waveform
length exceeds the instrument
memory.

The combination of waveform length
and oversampling is such that the
number of samples to be generated
exceeds the maximum memory.

Change either the waveform length
or the oversampling value so that
the product does not exceed the
instrument memory.

Compilation aborted. Waveform
length exceeds the generation limit.

The combination of waveform length
and oversampling is such that the
number of samples to be generated
exceeds the maximum memory.

Change either the waveform length
or the oversampling value so that
the product does not exceed the
instrument memory.

Maximum number of entries in
multipath table:10

The maximum number of paths that
you can define in 10.

Do not define more than ten paths.

The delay cannot be the same for
different paths.

No two paths can have the same
delay value.

Change the delay to a unique value.
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xxx

Shortcut Keys
Menu/Menu item Shortcut key
File Alt+F
File> Open Setup... Ctrl+O
File> Save Setup Ctrl+S
View Alt+V
Configure Alt+C
Waveform Alt+A
System Alt+S
Window Alt+W
Help Alt+H
xxx

RFXpress Options and AWG Models
Generic Signal

The following table lists the AWG models and options to generate generic signals using RFXpress.

Table 89: AWG models and options for generic signal generation
Instrument model Direct RF IF from AWG IQ from AWG Hardware signal

addition
AWG7102 Yes Yes Yes No
AWG7101 Yes Yes No No
AWG7052 No Yes Yes No
AWG7051 No Yes No No
AWG5014 No Yes Yes Yes
AWG5012 No Yes Yes Yes
AWG5004 No Yes Yes Yes
AWG5002 No Yes Yes Yes
xxx

UWB-WiMedia

The following table lists the AWG models and options to generate UWB-WiMedia signals using RFXpress.
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Table 90: AWG models and options for UWB-WiMedia signal generation
Instrument model Direct RF IF from

AWG
IQ from
AWG

Calibra-
tion

Remarks

AWG7102 – Opt 06 Yes, BandGroup1 and
BandGroup2

Yes Yes Yes Recommended
option for Direct RF
generation.

AWG7102 – Standard No Yes Yes Yes Not recommended for
Direct RF generation.

AWG7101– Standard No Yes No Yes N/A
AWG7101– Opt 02 Yes, BandGroup1 Yes No Yes Not recommended for

Direct RF generation.
AWG7052 No Yes Yes Yes N/A
AWG7051 No Yes No Yes N/A
AWG5014 No No Yes No Only Non hopping IQ.
AWG5012 No No Yes No Only Non hopping IQ.
AWG5004 No No No No N/A
AWG5002 No No No No N/A
xxx

AWG Specifications
You can refer to the specifications in the Technical Reference for AWG7000 Series Arbitrary Waveform
Generators Specifications and Performance Verifications, Tektronix part number 071-1853-XX.

You can view the document from Start > All Programs > Tektronix > AWG > Documentation > Technical
Reference Manual.

Interleave
The AWG7102 Option 06 supports the interleaving mode. Interleaving is a mode where the sampling
rate ranges from 10 GS/s to 20 GS/s. The following table shows the amplitude and sampling rates for the
interleaving and non-interleaving modes.

Table 91: Amplitude and sampling rates in non-Interleave and interleave modes
Non-Interleaving Interleaving
Amplitude (min,
max)

Sampling rate (min,
max)

Amplitude (min,
max)

Sampling rate (min,
max)

500 mVpp, 1 Vpp 10 MS/s, 10 GS/s 500 mVpp, 1 Vpp 10 GS/s, 20 GS/s
xxx

In the Interleaving mode, the output is available in a separate interleave connector as shown in the figure.
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As an example, in the non-interleave mode let the sampling rate be 20 GS/s and the original amplitude
samples be 0.1, 0.2 , 0.3, 0.4, 0.5 , 0.1, 0.2. This can be represented graphically as shown here.

This diagram is not drawn to scale.

In the interleave mode, alternate samples are output from each channel. That is, the samples are distributed
between the two channels as shown below:

Ch1 Ch2
0.1 0.2
0.3 0.4
0.5 0.1
0.2 0
xxx

This can be represented graphically as shown here.
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This diagram is not drawn to scale.

Zeroing
When Interleave is on, you can turn Zeroing on or off. This function is only available when Interleave is
available. If you compose waveform data that is divided into two channels, the zeroing function allows you
to select whether you want to handle each waveform as RZ (Return to Zero) or NRZ (Non Return to Zero).

If you turn the zeroing function on, the bandwidth increases. However, spurious characteristics will worsen
(increase in the frequency spectra that should not be output) and the amplitude range will be halved.
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PRBS Editor Starting Values
When the option Use different PRBS at the beginning is selected, the starting value for each PRBS
varies. The following table gives the initial shift register values and the PRBS ploynomial expression:

Table 92: Initial shift values and PRBS polynomial expressions
PRBS Initial PRBS Polynomial for the Standard PRBS
PRBS 7 0 0 0 0 0 0 1 X7+X6+1=0
PRBS 9 0 0 0 0 0 0 0 0 1 X9+X5+1=0
PRBS 15 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 X15 +x14+1=0
PRBS 16 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 X16+X14+X13+X11+1=0
PRBS 20 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 X20+X17+1=0
PRBS 21 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 X21+X19+1=0
PRBS 23 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 1 X23+X18+1=0
xxx

Amplifier Distortions
Nonlinear amplifier distortions (AM/AM and AM/PM) are calculated using the following simple equations:
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Nonlinear Impairments

AM/AM
Nonlinear modulator AM/AM impairments are calculated using the following equations:

The inphase and quadrature distortions are applied to the signal as follows:

AM/PM
Nonlinear modulator AM/PM impairments are calculated using the following equations:

The inphase and quadrature distortions are applied to the signal as follows:

120 RFXpress RFX100 User Manual



Index

Index

A
About basic operations, 7
Advanced settings,

AWG, 98
PSG, 101

Amplifier distortion, 119
Generic signal, 64
UWB-WiMedia, 88

Application, 12
select, 20

AWG, 8
control, 98
interleave, 116
models, 115
specifications, 116

C
Calibration, 42

IF/RF signals, 96
Compile Settings, 29

automatic, 30
Conformance mode, 68

hopping details, 73
packet details, 72
packet group details, 70

Conventions, 2
Custom mode, 69

MAC header, 84
packet group details, 74
packet sync sequence, 79
PHY header, 83
PLCP header, 78
PLCP preamble, 77
PPDU details, 76
PSDU, 79

D
Data files, 12

.rfd, 11
Distortion addition,

Amplifier distortion, 64

E
Editing carrier details, 55
Error messages,

Generic Signal, 109
Miscellaneous, 113
UWB-WiMedia, 111

Exiting the software, 11
Eye diagram, 109

F
File name extensions and

application directories, 11
File,

data, 12
File(1)Samples, 37
File(2)Symbols, 38
menu, 12
setup, 12
.smp, 11

G
Gated noise, 92
Graphs, 26

CCDF, 106
Constellation, 108
Eye diagram, 109
I(t),Q(t), 105
Pulse shape, 104
Spectrum, 107

I
I/Q Impairments,

Carrier leakage, 85
Hardware skew, 64
I/Q Imbalance, 86
Non-linear distortion, 63
Quadrature error, 61

Importing data from a file or an
oscilloscope, 22

Installation Manual, 4
Installation, 4

Instruments,
Control, 98
Find, 26
Importing data, 24
Oscilloscope, 100

Interference addition,
Gated noise, 92
Offset addition, 91
radar, 95
real-world signal, 95
Signal addition, 66
Sinusoidal interference, 94
WiFi (802.11a), 95
WiFi (MIMO), 95
WiMax , 95

Interleave, 116

M
Menu bar, 12
Minimum system requirements, 3
Multipath,

parameters for carriers, 65
parameters for UWB-

WiMedia, 89
reference path, 65

N
Non-linear impairments, 120

O
On/Off, 21
Option,

installation, 32
RFXpress and AWG

models, 115
software, 3

Ordering options, 3
Overview, 33

P
Power ramping, 60
PRBS editor, 35

RFXpress RFX100 User Manual 121



Index

Process preferences, 48

R
Reference path,

values, 89
Related documentation, 1
RFXpress Options and AWG

models, 115
Run, 21

S
Setup,

base data, 57
file, 12
filter, 58
IF signal generation, 5
IQ signal generation, 5
modulation, 57
multi carrier, 53
RF signal generation, 4
.rfs, 12
single carrier, 53

Shortcut keys, 115
Signal generation, 10

conformance mode, 68
custom mode, 69

Starting the software, 10

Status bar, 17
Symbol Map, 39

T
Toolbar, 16

W
Waveform list, 17
Welcome, 1

Z
Zoom, 104

I(t), Q(t), 105
Spectrum, 107

122 RFXpress RFX100 User Manual


	toc
	Introduction
	Welcome
	Related Documentation
	Conventions
	Feedback

	Getting Started
	Minimum System Requirements
	Ordering RFXpress
	Installation
	Connection Setups
	Setup for RF Signal Generation
	Setup for IF Signal Generation
	Setup for AWG IQ Signal Generation


	Operating Basics
	About Basic Operations
	Overview of the Software
	Starting the Software
	Using the Software to Create a Signal
	Exiting the Software
	File Name Extensions and Directories
	Applications, Setup Files, and Data Files
	Menus and Toolbars
	Menu Bar
	Standard Toolbar
	Status Bar
	Waveform List

	Toolbar Options
	Select Application
	Signal Type
	Compile
	On/Off
	Run

	Dialog Boxes
	Open Setup
	Open Data
	Save Setup
	Save Data
	Import Data from a File
	Import from Tektronix Oscilloscope
	Find Instruments
	Graph
	Compile Settings
	Option Installation
	Overview

	Generic Signal Dialog Boxes
	PRBS Editor
	Data Source Values
	Modulation File1(Samples)
	Modulation File2(Symbols)
	Symbol Map

	UWB-WiMedia Dialog Boxes
	Calibration
	Marker Mapping
	Tone Nulling
	Hopping Pattern
	Process Preferences
	Custom Settings
	Frame Payload


	Creating a Generic Signal
	Setup
	Single Carrier
	Multi Carriers
	Editing Carrier Details
	Selecting the Base Data
	Modulation for Carriers
	Filter for Carriers

	Power Ramping
	Power Ramping Parameters

	I/Q Impairments
	Carrier Leakage for Single Carrier
	Quadrature Error for Carriers
	I/Q Imbalance for Carriers
	Non-Linear Distortions for Carriers
	Hardware Skew for Carriers

	Distortion Addition
	Amplifier Distortion for Carriers

	MultiPath 
	Multipath Parameters for Carriers

	Interference Addition
	Signal Addition for Carriers
	Offset for Carriers
	Sinusoidal for Carriers


	Creating a UWB-WiMedia Signal
	Conformance Mode
	Custom Mode
	Conformance Mode Setup
	Packet Group Details for Conformance Mode
	Packet Details for Conformance Mode
	Hopping Details for Conformance Mode

	Custom Mode Setup
	Packet Group Details for Custom Mode
	Setting PPDU Details
	PLCP Preamble
	PLCP Header
	PSDU
	Packet Sync Sequence
	PHY Header
	MAC Header

	I/Q Impairments
	Carrier Leakage for UWB-WiMedia
	Quadrature Error for UWB-WiMedia
	I/Q Imbalance for UWB-WiMedia
	Non-Linear Distortion for UWB-WiMedia
	Hardware Skew for UWB-WiMedia

	Distortion Addition
	Amplifier for UWB-WiMedia

	MultiPath
	Multipath Parameters for UWB-WiMedia

	Interference Addition
	Signal Addition for UWB-WiMedia
	Offset for UWB-WiMedia
	Gated Noise for UWB-WiMedia
	Sinusoidal for UWB-WiMedia
	Real-World Signal Interference 


	Calibration for UWB-WiMedia Signals
	Using Calibration for IF/RF Signals

	Instrument Control
	Controlling an Instrument
	Controlling an Arbitrary Waveform Generator (AWG)
	Connecting to and Controlling an Oscilloscope
	Connecting to and Controlling a Performance Signal Generator (PS

	Graphing
	Zooming Graphs
	Pulse Shape
	I(t), Q(t)
	CCDF Plot
	Spectrum
	Constellation Plotting
	Eye Diagram

	Reference
	Error Messages
	Error Messages for Generic Signal
	Error Messages for UWB-WiMedia
	Miscellaneous Error Messages
	Miscellaneous Error Messages 2

	Shortcut Keys
	RFXpress Options and AWG Models
	AWG Specifications
	Interleave
	PRBS Editor Starting Values
	Amplifier Distortions
	Nonlinear Impairments




<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /All
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Warning
  /CompatibilityLevel 1.3
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /DetectCurves 0.1000
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedOpenType false
  /ParseICCProfilesInComments true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveDICMYKValues true
  /PreserveEPSInfo true
  /PreserveFlatness true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /CropColorImages true
  /ColorImageMinResolution 150
  /ColorImageMinResolutionPolicy /OK
  /DownsampleColorImages true
  /ColorImageDownsampleType /Average
  /ColorImageResolution 300
  /ColorImageDepth -1
  /ColorImageMinDownsampleDepth 1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.40
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /CropGrayImages true
  /GrayImageMinResolution 150
  /GrayImageMinResolutionPolicy /OK
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 300
  /GrayImageDepth -1
  /GrayImageMinDownsampleDepth 2
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.40
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /CropMonoImages true
  /MonoImageMinResolution 1200
  /MonoImageMinResolutionPolicy /OK
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /CheckCompliance [
    /None
  ]
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile ()
  /PDFXOutputConditionIdentifier ()
  /PDFXOutputCondition ()
  /PDFXRegistryName (http://www.color.org)
  /PDFXTrapped /Unknown

  /SyntheticBoldness 1.000000
  /Description <<
    /FRA <>
    /JPN <FEFF3053306e8a2d5b9a306f30019ad889e350cf5ea6753b50cf3092542b308000200050004400460020658766f830924f5c62103059308b3068304d306b4f7f75283057307e30593002537052376642306e753b8cea3092670059279650306b4fdd306430533068304c3067304d307e305930023053306e8a2d5b9a30674f5c62103057305f00200050004400460020658766f8306f0020004100630072006f0062006100740020304a30883073002000520065006100640065007200200035002e003000204ee5964d30678868793a3067304d307e30593002>
    /DEU <>
    /PTB <>
    /DAN <>
    /NLD <>
    /ESP <>
    /SUO <>
    /ITA <>
    /NOR <>
    /SVE <>
    /ENU <>
  >>
>> setdistillerparams
<<
  /HWResolution [1200 1200]
  /PageSize [612.000 792.000]
>> setpagedevice


